Bug 569 - Please make wget the default application for urpmi
: Please make wget the default application for urpmi
Status: RESOLVED INVALID
Product: Desktop Features
Classification: ROSA Desktop
Component: All
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 09:18 MSD by FirstLevel
Modified: 2013-08-29 07:41 MSD (History)
6 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
urpmi-any-downloader.txt (1.84 KB, text/plain)
2012-07-24 12:44 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-07-24 09:18:36 MSD
Please make wget the default application for urpmi
Because with aria2 (current default application for urpmi) there are some errors like this (in russian) in many network configurations:

#urpmi opera
    $MIRRORLIST: media/non-free/updates/opera-12.00-2-rosa.lts2012.0.i586.rpm
...извлечение не удалось:        0B/s|/var/cache/urpmi/partial/opera-12.00-2-rosa.lts2012.0.i586.rpm
...извлечение не удалось:        0B/s|/var/cache/urpmi/partial/opera-12.00-2-rosa.lts2012.0.i586.rpm
сбой aria2: завершён с 19

Не удалось загрузить opera-12.00-2-rosa.lts2012.0.i586.rpm
Повторить попытку? (y/N) N
...извлечение не удалось: сбой aria2: завершён с 19
Comment 1 Pavel Shved 2012-07-24 10:27:14 MSD
Perhaps, this bug has a lot of history that I'm not aware of.  Is it really aria's error rather than the server it tried to download from was inavailable, internet was offline, etc?  Does "urpmi opera --downloader wget" succeed, while the default does not?

From manual we see that aria2's exit code 19 means that "name resolution failed"; would changing the downloader help?
Comment 2 FirstLevel 2012-07-24 10:32:20 MSD
The author of case have told that after changing aria2 to wget problem is solved.
Comment 3 FirstLevel 2012-07-24 10:33:51 MSD
I have such problem with firewall like MS TMG.
Comment 4 Pavel Shved 2012-07-24 10:54:32 MSD
(In reply to comment #2)
> The author of case have told that after changing aria2 to wget problem is
> solved.

Does curl also cause errors?
Comment 5 FirstLevel 2012-07-24 12:44:43 MSD
Created attachment 429 [details]
urpmi-any-downloader.txt
Comment 6 FirstLevel 2012-07-24 12:45:23 MSD
(In reply to comment #5)
> Created attachment 429 [details]
> urpmi-any-downloader.txt

(In reply to comment #4)
> (In reply to comment #2)
> > The author of case have told that after changing aria2 to wget problem is
> > solved.
> 
> Does curl also cause errors?

I have attached urpmi-any-downloader.txt with output of urpmi with downloaders.
Comment 7 Postnikov Dmitry 2012-07-25 00:59:13 MSD
Try: urpmi bburn --downloader "aria2 --async-dns false"
Comment 8 FirstLevel 2012-07-25 08:36:40 MSD
(In reply to comment #7)
> Try: urpmi bburn --downloader "aria2 --async-dns false"

In russian:

# urpmi bbrun --downloader \"aria2 --async-dns false\"


    $MIRRORLIST: media/contrib/updates/bbrun-1.6-9-rosa.lts2012.0.i586.rpm
...извлечение не удалось:        0B/s|/var/cache/urpmi/partial/bbrun-1.6-9-rosa.lts2012.0.i586.rpm
...извлечение не удалось:        0B/s|/var/cache/urpmi/partial/bbrun-1.6-9-rosa.lts2012.0.i586.rpm
сбой aria2: завершён с 19

Не удалось загрузить bbrun-1.6-9-rosa.lts2012.0.i586.rpm
Повторить попытку? (y/N) N
...извлечение не удалось: сбой aria2: завершён с 19

Установка не удалась, отсутствуют некоторые файлы:
    http://mirror.yandex.ru/rosa/rosa2012lts/repository/i586/media/contrib/updates/bbrun-1.6-9-rosa.lts2012.0.i586.rpm
Возможно, необходимо обновить базу данных urpmi

Попробовать в любом случае? (y/N) N
Comment 9 JDronova 2012-07-31 11:44:29 MSD
(In reply to comment #1)
> Perhaps, this bug has a lot of history that I'm not aware of.

From historical point of view I can confirm that people on Mandriva forums had always had troubles with aria2 since it was introduced (around 2008, but I'm not sure). To shift to wget would be nice empirical decision.
Comment 10 Dmitry Mikhirev 2012-08-07 11:27:20 MSD
I rember many suggestions on forums to users who had some problems with package installation to switch to wget. Personally I have never experienced problems with aria2 and I don't remember if aria2 was a real cause of any users' problem. I suppose that there could be some aria2 errors many years ago, but not now. Another possibility is that aria2 does not treat correctly some ISP-side errors that I have never met.
Comment 11 Postnikov Dmitry 2012-08-08 18:17:35 MSD
I have had problems with nebylo aria2. Now aria2 "licked." And it is more informative and better holding channel, and more stable rate. With wget it does not compare! She has a very high functional and work in different modes of transmission. 
I see no reason to change it to wget. The more user opportunity, as to choose a download program. He may at its sole discretion to select the desired program and use it.
Another thing, if user is too lazy to choose ... :)
Comment 12 Aleksandr Kazantcev 2012-08-13 13:53:18 MSD
Answer - we not doing it. With multiple mirrors aria2 hase more better result. Wget has not make switch to another mirror from list, it's not work properly on some VPN.

Feature request rejected.
Comment 13 Eugene Kanter 2013-08-29 07:41:02 MSD
It took me a while to figure it out because --wget option is not listed in

man urpmi

In my case aria2c is too inpatient when working ftp protocol over http proxy and overloading proxy with numerous duplicate GET requests.
Interestingly, when I tried aria2c command to get the same rpm file using the same proxy from the same mirror.yandex.ru it sent only one GET request and patiently waited for proxy to respond. It looks like urpmi is pushing aria2c engine differently then aria2c command line does.

using --wget option solved my problem.