Bug 567 - I can not add the application icon found on SW
: I can not add the application icon found on SW
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 14:43 MSD by FirstLevel
Modified: 2013-11-15 14:22 MSK (History)
5 users (show)

See Also:
RPM Package: rosapanel-1.0-30.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-07-23 14:43:07 MSD
Description of problem:
If I open SimpleWelcome on application tab and drag icon of aplication on rosapanel the icon is added correctly.
But if I search some application in SimpleWelcome typing text into the search bar  I can not add this icon found on SW. in the beginning it looks like the previous action, but at the end icon of application daos not apperar on rosapanel

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Ural Mullabaev 2012-07-23 16:50:45 MSD
This behavior isn't for everything. You can drag some general applications from SimpleWelcome search results to the RocketBar, but can't add some configuration dialogs (KDE Control Modules).
Comment 2 FirstLevel 2012-07-23 17:10:41 MSD
For example, I can not do this operation for Chromium browser.
Comment 3 Ural Mullabaev 2012-07-23 17:25:38 MSD
It's strange. We'll deal with it.
Comment 4 Aleksey Yermakov 2012-08-06 13:05:07 MSD
Investigated the issue. Found regress in KDE: KDesktopFile class should check 'apps' storage if it gets relative desktop-file path. It stoped doing so. But when we getting search query match only data available is relative desktop-file path which with KDesktopFile worked fine before.
Comment 5 Ural Mullabaev 2012-08-29 14:53:54 MSD
*** Bug 711 has been marked as a duplicate of this bug. ***
Comment 6 Ural Mullabaev 2012-08-29 15:01:52 MSD
It seems to upstream bug, need deep investigation.
Comment 7 Denis Silakov 2013-11-15 14:22:20 MSK
Not sure about the final state of this bug in Marathon, but even it is not fixed, we consider such cosmetic issues as non-crucial and don't work on them for Marathon.

If you are able to reproduce this bug in modern Desktop Fresh R1, please create a separate bug.