Bug 5641 - drakxinstaller
: drakxinstaller
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-27 12:38 MSD by Shalok Shalom
Modified: 2016-01-19 19:47 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shalok Shalom 2015-05-27 12:38:45 MSD
The installer choose on any of my devices the GMT time by default:

How many people set up there clock for GMT.

I prefer the local time and think, that is a nice option for the default setting.


Steps to Reproduce:
1. Start ROSA live or the Installer
2. Go ahead, until you find the time setting.

thanks a lot :)
Comment 1 Konstantin Vlasov 2015-05-27 15:00:50 MSD
UTC is preferrable because it does not require changing BIOS time when local time changes (e.g. during travel, or for daylight saving), that's why it is selected by default.

If at the moment of installation you have network connected, the installer tries to check for Internet time and suggest UTC or non-UTC, depending on which of the options is closer to your real time (based on the selected location). However, it will not work if you have password-protected Wi-Fi as the only network.
Comment 2 Shalok Shalom 2015-05-27 15:16:11 MSD
Thanks a lot, to make this clear to me.

I think still, that the very most people will not able to reproduce this decision, especially since the very most people never travel with there device in another country/time zone: 

80% of the laptop operators use there device just at home. :)

And it is possible to change the time (zone) in KDE`s clock settings.
Comment 3 Konstantin Vlasov 2015-05-27 15:52:56 MSD
(In reply to comment #2)
> I think still, that the very most people will not able to reproduce this
> decision, especially since the very most people never travel with there
> device in another country/time zone: 
> 
> 80% of the laptop operators use there device just at home. :)

And why would we need to sacrifice the rest 20%? What are the downsides of UTC, except personal preferences?

> And it is possible to change the time (zone) in KDE`s clock settings.

The difference is not what you can and what you cannot do, but the consequences of these actions. If BIOS is set to local time it will be changed along with OS time. It may lead to problems if, for example, you have more than one system installed. Daylight saving time comes into effect, OS automatically changes time 1 hour forward (and since BIOS time is set to local, it changes too). Then you boot another system, and it also detects that daylight time started, and forwards clock 1 hour further. Now you have wrong system time. But if BIOS is set to UTC, then OS time changes only within OS itself, without affecting BIOS and, therefore, without affecting other systems.
Comment 4 Shalok Shalom 2015-05-27 16:21:34 MSD
(In reply to comment #3)


> And why would we need to sacrifice the rest 20%? What are the downsides of
> UTC, except personal preferences?

Because 80 % are much more than 20 % and then come the desktop computer to that calculation. The downside is, that the draxinstaller is currently the only one, which i know of, that set the WRONG time for 95% of all users. 

> > And it is possible to change the time (zone) in KDE`s clock settings.
> 
> The difference is not what you can and what you cannot do, but the
> consequences of these actions. If BIOS is set to local time it will be
> changed along with OS time. It may lead to problems if, for example, you
> have more than one system installed. Daylight saving time comes into effect,
> OS automatically changes time 1 hour forward (and since BIOS time is set to
> local, it changes too). Then you boot another system, and it also detects
> that daylight time started, and forwards clock 1 hour further. Now you have
> wrong system time. But if BIOS is set to UTC, then OS time changes only
> within OS itself, without affecting BIOS and, therefore, without affecting
> other systems.

Ok, that sound useful. I think such people can choose UTC, while the very most users are confused by this decision.
Comment 5 Konstantin Vlasov 2015-05-27 17:06:44 MSD
(In reply to comment #4)
> Ok, that sound useful. I think such people can choose UTC, while the very
> most users are confused by this decision.

They won't know about this problem until they bump right into it. And even when they meet the problem, only very few users will know that using UTC time is actually a solution.
Comment 6 Denis Silakov 2016-01-19 19:47:34 MSK
It doesn't look like we are going to change installer behavior in this area.