Bug 563 - hear the crackling when watching video through vlc with pulseaudio
: hear the crackling when watching video through vlc with pulseaudio
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 08:48 MSD by FirstLevel
Modified: 2014-06-09 08:53 MSD (History)
4 users (show)

See Also:
RPM Package: vlc-2.0.1-2plf-plf2012.0.x86_64.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
lspci (2.18 KB, text/plain)
2012-07-23 08:48 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-07-23 08:48:18 MSD
Created attachment 422 [details]
lspci

Description of problem:
If I enable pulseaudio system I hear the crackling when watching video through vlc  (mkv or avi). mp3 sounds well. And other applications works well with pulseaudio.
If I enable alsa and disable pulseaudio VLC works well too.
I have removed ~/.pulse and ~/.config/vlc  but situation did not change.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Pavel Shved 2012-07-23 12:09:58 MSD
+1.  Sound also cracks if I watch DVD via VLC at my home PC with pulseaudio enabled.  mplayer worked well for the same movies.  I have Audigy2 sound card (emu10k1 driver afaik).
Comment 2 Alexander Burmashev 2012-07-23 12:17:00 MSD
can you try this:

1) open /etc/pulse/default.pa
2) find string
load-module module-udev-detect
3) add tsched=0 there, so the string looks
load-module module-udev-detect tsched=0

4) Save the file and restart PC/pulseaudio
Comment 3 Pavel Shved 2012-07-24 23:28:08 MSD
(In reply to comment #2)
> can you try this:
> 
> 1) open /etc/pulse/default.pa
> 2) find string
> load-module module-udev-detect
> 3) add tsched=0 there, so the string looks
> load-module module-udev-detect tsched=0
> 
> 4) Save the file and restart PC/pulseaudio

This helped me!  The crackling is gone from VLC.  And there seems nothing wrong with other applications such as Skype, romp, amaroK, etc.
Comment 4 Postnikov Dmitry 2012-07-25 00:04:34 MSD
(In reply to comment #3)
> (In reply to comment #2)
> > can you try this:
> > 
> > 1) open /etc/pulse/default.pa
> > 2) find string
> > load-module module-udev-detect
> > 3) add tsched=0 there, so the string looks
> > load-module module-udev-detect tsched=0
> > 
> > 4) Save the file and restart PC/pulseaudio
> 
> This helped me!  The crackling is gone from VLC.  And there seems nothing
> wrong with other applications such as Skype, romp, amaroK, etc.


This method is described in Errata, paragraph 4.3:
http://wiki.rosalab.ru/ru/index.php/Errata_ROSA_Marathon_2012
:)
Comment 5 Alexander Burmashev 2012-07-25 00:08:08 MSD
Then maybe this workaround can be considered a fix and be applied by default ?
Comment 6 Postnikov Dmitry 2012-07-25 00:11:13 MSD
(In reply to comment #5)
> Then maybe this workaround can be considered a fix and be applied by default
> ?

I guess. Since I'm always at just, such manipulation, and spend the rest of it is talking about. Otherwise ... wheezing sound at all.
Comment 7 FirstLevel 2014-06-09 08:53:25 MSD
User has applied workaround and all works well.
I'll close this bug.