Bug 5627 - printing fails since cups-filters invoke gs with incorrect parameter
: printing fails since cups-filters invoke gs with incorrect parameter
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-26 14:59 MSD by Denis Silakov
Modified: 2015-06-01 16:49 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2015-05-26 14:59:24 MSD
It turned out that our cups-filters still pass "-sDEVICE=pswrite" parameter to gs. However, "pswrite" is replaced with "ps2write" in modern gs so the printing job fails. This is caused by the fact that ghostscript is not available during cups-filters build, so they fallback to the old "pswrite" device.

See http://forum.rosalab.ru/viewtopic.php?f=53&t=5002&p=45216 for discussion.
Comment 1 Denis Silakov 2015-05-26 15:00:02 MSD
Advisory:
Fixed cups-filters to pass correct sDEVICE parameter to ghostscript.

Build lists:
https://abf.io/build_lists/2504479
https://abf.io/build_lists/2504480
Comment 2 Vladimir Potapov 2015-05-27 18:55:09 MSD
The update is sent to expanded testing
**************************************
Comment 3 Vladimir Potapov 2015-06-01 16:45:20 MSD
cups-filters-1.0.67-3
https://abf.io/build_lists/2504479
https://abf.io/build_lists/2504480
************************* Advisory ****************************
Fixed cups-filters to pass correct sDEVICE parameter to ghostscript.
***************************************************************
QA Verified