Bug 562 - Start GUI program from root in Konsole is crashes
: Start GUI program from root in Konsole is crashes
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 19:32 MSD by Postnikov Dmitry
Modified: 2012-07-24 15:03 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
rt1 (251.50 KB, image/png)
2012-07-22 19:32 MSD, Postnikov Dmitry
Details
su-- (127.26 KB, image/png)
2012-07-23 20:00 MSD, Postnikov Dmitry
Details
su--2 (134.25 KB, image/png)
2012-07-23 20:03 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2012-07-22 19:32:18 MSD
Created attachment 421 [details]
rt1

Description of problem:
ROSA 2012 RP1 iso 369th
Start GUI program from root in Konsole is crashes. From user in Konsole - its OK.
See att.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Alexander Burmashev 2012-07-23 10:13:13 MSD
what GUI program, any of them ? Was this behavior reproducible in release image ?
Comment 2 Postnikov Dmitry 2012-07-23 10:42:56 MSD
I tried to run Kwrite, Okular, Gwenview program, they are not started. Screenshot attached last message. Now tried to run Dolphin, Kopete, Amarok program. All the same, do not start.
That's all there is not only in this iso image. It was still in the 357th iso.
Comment 3 Alexander Burmashev 2012-07-23 10:43:57 MSD
Just to be sure - this is installed system, isn't it ?
Comment 5 Denis Silakov 2012-07-23 16:59:57 MSD
This is not a bug, but documented and expected 'su' behavior which can be observed in almost every distribution, not only in ROSA.

The thing is that when some GUI program is being launched from console, it needs to connect to X server which is run under different user. If the server is not configured to accept all connections (and such a configuration should be normally considered as a security hole), it will refuse the connection. The error you will see can depend on application type (pure X11 app, KDE app, etc.).

So just use 'su -' or 'su -l'. Or 'root terminal' KDE application.
Comment 6 Postnikov Dmitry 2012-07-23 19:59:42 MSD
Yes, I understood.
I tried "su -", the program will start, but with a different theme design. No theme is Elementary. Screenshot att. next message.
Comment 7 Postnikov Dmitry 2012-07-23 20:00:05 MSD
Created attachment 424 [details]
su--
Comment 8 Postnikov Dmitry 2012-07-23 20:03:04 MSD
Created attachment 425 [details]
su--2
Comment 9 Alexander Burmashev 2012-07-23 20:03:56 MSD
this is expected behaviour.
Comment 10 Pavel Shved 2012-07-24 10:29:37 MSD
(In reply to comment #9)
> this is expected behaviour.

But what is the correct way to run a GUI program under root, with the brand ROSA theme?

Programs that work with files (such as file managers, kdirstat-like programs) sometimes need to be run from root.
Comment 11 Denis Silakov 2012-07-24 14:42:09 MSD
Alt-F2 -> "kdesu <program>".

Launches successfully Dolphin, Gwenview, Kwrite and other programs mentioned in this bug.
Comment 12 Alexander Burmashev 2012-07-24 14:43:10 MSD
It does, but i am afraid that it uses root user variables, so there is a fair chance that theme  will be broken
Comment 13 Postnikov Dmitry 2012-07-24 14:44:58 MSD
Yes, kdesu <program> is work. But theme not Elementary.
Comment 14 Denis Silakov 2012-07-24 14:56:44 MSD
On the other hand, this allows you to distinguish programs with root privileges from ordinary ones:)
Comment 15 Alexander Burmashev 2012-07-24 14:57:48 MSD
As far as i can imagine we can populate root user  dir with some predefined settings, but i am not sure if it is ok.
Comment 16 Postnikov Dmitry 2012-07-24 15:03:59 MSD
Yes. This is understandable. But there is one problem. When writing "kdesu dolphin" section and mount other disk. Then close the program and open the Dolphin from the user. What this section is not to look. He writes that "I can not find the folder ...". We have to go back to konsole of the root and do "umount /dev/sda...".