Bug 5589 - [UPDATE REQUEST] draklive-install-1.60-1, drakxtools-14.59-1
: [UPDATE REQUEST] draklive-install-1.60-1, drakxtools-14.59-1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-21 22:24 MSD by Konstantin Vlasov
Modified: 2015-06-09 15:11 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2015-05-21 22:24:47 MSD
Fixes and improvements.
Comment 1 Konstantin Vlasov 2015-05-21 22:26:23 MSD
drakxtools:
https://abf.rosalinux.ru/build_lists/2502727
https://abf.rosalinux.ru/build_lists/2502728

Advisory:
Removed non-UTF8 option from language selection.
Minor locale fixes.

draklive-install:
https://abf.rosalinux.ru/build_lists/2503369
https://abf.rosalinux.ru/build_lists/2503370

Advisory:
1. Added bootloader option for not adding secondary systems in boot menu (useful if this is a secondary system itself).
2. Added bootloader option for portable initrd (so that initrd was not host-only and could work with different hardware - useful when installing ROSA on portable device).
3. When installing on real hardware, VBox Additions are automatically removed.
4. Completely rewritten procedure for copying files during installation.
5. Fixed EFI installation (ROSA boot menu entry was not added into EFI firmware boot list).

Test images:
64-bit: https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/product_build_lists/11244
32-bit: https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/product_build_lists/11245
Comment 2 Vladimir Potapov 2015-05-23 10:06:43 MSD
I make test install from live mode with separate /boot and / on btrfs.
Progress indicator and installation graphics don't change
**********************************************************
QA Denied

P.S. Test image mount with options relatime (not noatime). It's critical decreate live resource.

Аfter installation (live):

dmsetup status /dev/mapper/live-rw
0 17801216 snapshot 1001560/1048576 3912
Comment 3 Konstantin Vlasov 2015-05-27 19:31:48 MSD
Interface freezing should be fixed now.

drakxtools:
https://abf.rosalinux.ru/build_lists/2504999
https://abf.rosalinux.ru/build_lists/2505000

Advisory:
1. Removed non-UTF8 option from language selection.
2. Removed localedrake (it is superseded by DE-specific settings anyway).
3. Removed RAIDs from the disks list on the installation scheme page (they caused crash when selected).
4. EFI partition was not assigned when selecting 'Use existing partitions' scheme in EFI mode.
5. In EFI mode the 'Use existing partitions' scheme is no longer displayed if EFI partition does not exist.
6. If GeoIP failed first time, it is requested again before timezone selecting, in case network is not missing but simply slow.
7. Minor locale fixes.


draklive-install:
https://abf.rosalinux.ru/build_lists/2505001
https://abf.rosalinux.ru/build_lists/2505002

Advisory:
1. Added bootloader option for not adding secondary systems in boot menu (useful if this is a secondary system itself).
2. Added bootloader option for portable initrd (so that initrd was not host-only and could work with different hardware - useful when installing ROSA on portable device).
3. When installing on real hardware, VBox Additions are automatically removed.
4. Completely rewritten procedure for copying files during installation.
5. Fixed EFI installation (ROSA boot menu entry was not added into EFI firmware boot list).


Test images with these updates, dracut (noatime for Live), systemd (/boot/efi automount fixes, disabled for Live), rosa-online (avoid empty icon in system tray):
64-bit: https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/product_build_lists/11356
32-bit: https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/product_build_lists/11357
Comment 4 Vladimir Potapov 2015-05-28 08:41:51 MSD
I check live mode for real hardware and install mode for virtualbox.
GeoIP don't work
Comment 5 Vladimir Potapov 2015-05-28 15:12:11 MSD
For my laptop lenovo g670 and install from grub menu progress indicator and installation graphics don't change
Comment 6 Vladimir Potapov 2015-05-28 15:18:01 MSD
Is I set up grub "by link to menu", all rosa-systems showed in menus as FRESH R5.
In nickel too. http://bugs.rosalinux.ru/show_bug.cgi?id=5611
Comment 7 Vladimir Potapov 2015-05-28 21:00:45 MSD
*********************
QA Denied
Comment 8 Konstantin Vlasov 2015-06-02 22:37:44 MSD
1. GeoIP discussed in private E-mail, it is caused by outdated local database and has nothing to do with the installer.
2. Freesing progress indicator was reported as non-reproducible in Nickel, so it should also be fixed in Fresh since they are in sync.
3. Wrong names in linked Grub menu was also caused by other packages, discussed in #5611.


drakxtools:
https://abf.rosalinux.ru/build_lists/2506931
https://abf.rosalinux.ru/build_lists/2506932

Advisory:
1. Removed non-UTF8 option from language selection.
2. Removed localedrake (it is superseded by DE-specific settings anyway).
3. Removed RAIDs from the disks list on the installation scheme page (they caused crash when selected).
4. EFI partition was not assigned when selecting 'Use existing partitions' scheme in EFI mode.
5. In EFI mode the 'Use existing partitions' scheme is no longer displayed if EFI partition does not exist. In non-EFI mode it is also not displayed, if there is no hard disk available for bootloader installation (that is, if there are no MBR disks, only GPT, and no one contains a BIOS Boot Partition).
6. Fixed mount point suggestion for /boot/efi (sometimes it was not suggested when selecting an existing EFI partition; or, to the contrary, suggested for non-EFI partitions).
7. If GeoIP failed first time, it is requested again before timezone selecting, in case network is not missing but simply slow.
8. Minor locale fixes.
9. Fixes for nut-server and drakups.


draklive-install:
https://abf.rosalinux.ru/build_lists/2506598
https://abf.rosalinux.ru/build_lists/2506599

Advisory:
1. Added bootloader option for not adding secondary systems in boot menu (useful if this is a secondary system itself).
2. Added bootloader option for portable initrd (so that initrd was not host-only and could work with different hardware - useful when installing ROSA on portable device).
3. When installing on real hardware, VBox Additions are automatically removed.
4. Completely rewritten procedure for copying files during installation.
5. Fixed EFI installation (ROSA boot menu entry was not added into EFI firmware boot list).


Test images:
64-bit: https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/product_build_lists/11474
32-bit: https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/product_build_lists/11473
Comment 9 Vladimir Potapov 2015-06-05 12:14:11 MSD
The update is sent to expanded testing
**************************************
Comment 10 Vladimir Potapov 2015-06-09 14:50:21 MSD
drakxtools-14.59-1
https://abf.rosalinux.ru/build_lists/2506931
https://abf.rosalinux.ru/build_lists/2506932

draklive-install-1.60-1
https://abf.rosalinux.ru/build_lists/2506598
https://abf.rosalinux.ru/build_lists/2506599
******************************** Advisory ****************************
drakxtools:
1. Removed non-UTF8 option from language selection.
2. Removed localedrake (it is superseded by DE-specific settings anyway).
3. Removed RAIDs from the disks list on the installation scheme page (they caused crash when selected).
4. EFI partition was not assigned when selecting 'Use existing partitions' scheme in EFI mode.
5. In EFI mode the 'Use existing partitions' scheme is no longer displayed if EFI partition does not exist. In non-EFI mode it is also not displayed, if there is no hard disk available for bootloader installation (that is, if there are no MBR disks, only GPT, and no one contains a BIOS Boot Partition).
6. Fixed mount point suggestion for /boot/efi (sometimes it was not suggested when selecting an existing EFI partition; or, to the contrary, suggested for non-EFI partitions).
7. If GeoIP failed first time, it is requested again before timezone selecting, in case network is not missing but simply slow.
8. Minor locale fixes.
9. Fixes for nut-server and drakups.

draklive-install: 1. Added bootloader option for not adding secondary systems in boot menu (useful if this is a secondary system itself).
2. Added bootloader option for portable initrd (so that initrd was not host-only and could work with different hardware - useful when installing ROSA on portable device).
3. When installing on real hardware, VBox Additions are automatically removed.
4. Completely rewritten procedure for copying files during installation.
5. Fixed EFI installation (ROSA boot menu entry was not added into EFI firmware boot list).
*************************************************************
QA Verified