Bug 5577 - vdpauinfo: failed to open VDPAU backend libvdpau_nvidia.so
: vdpauinfo: failed to open VDPAU backend libvdpau_nvidia.so
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Hardware
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Groups for solving hardware issues.
: Eugene Shatokhin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-19 12:32 MSD by Andrey Ponomarenko
Modified: 2015-05-19 15:20 MSD (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2015-05-19 12:32:55 MSD
Description of problem:

The vdpauinfo failed to run on Optimus computer with error:

Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1

The file /usr/lib/vdpau/libvdpau_nvidia.so.1 should be provided by x11-driver-video-nvidia346 (try urpmf). I have the x11-driver-video-nvidia346 installed, but libvdpau_nvidia.so.1 is not installed for some reason.

HW probe: http://hw.rosalinux.ru/index.php?probe=9a99df2417

The error is the same on the computer with Radeon + Intel hybrid graphics.

Version-Release number of selected component (if applicable): R5


How reproducible:


Steps to Reproduce:
1. urpmi vdpauinfo
2. run vdpauinfo
3.
Comment 1 Eugene Shatokhin 2015-05-19 15:20:21 MSD
On x86_64, /usr/lib64/vdpau/libvdpau_nvidia.so.1 is provided by x11-driver-video-nvidia346.

If vdpauinfo looks for it in /usr/lib instead, it is vdpauinfo that should be fixed, I suppose.