Bug 5547 - Bash complains "command not found" after the recent updates
: Bash complains "command not found" after the recent updates
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal minor
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-14 13:10 MSD by Eugene Shatokhin
Modified: 2015-08-07 17:26 MSD (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2015-05-14 13:10:59 MSD
After the recent updates (incl. systemd and others), a warning started to appear each time I login to a virtual console, connect to the system via SSH or open a new tab in Konsole: 

  bash: [General]: command not found

I have seen no serious issues related to this so far, but the message is annoying.

The logs, etc.: http://hw.rosalinux.ru/index.php?probe=4f646ad465
Comment 1 Eugene Shatokhin 2015-08-07 17:26:38 MSD
Well, strace has shown that the problem is in ~/.i18n that bash tries to execute automatically on start. That file indeed starts from "[General]":

-------------------
[General]
LC_TELEPHONE=en_US.UTF-8
LC_CTYPE=en_US.UTF-8
LANGUAGE=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_COLLATE=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_NUMERIC=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_TIME=en_US.UTF-8
LANG=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_MESSAGES=en_US.UTF-8
-------------------

If I remove that line, the problem goes away. The newer releases of ROSA Fresh do not have this line in ~/.i18n either. Might be, some earlier update went wrong.

No other users seem to experience this problem. In case they do, the workaround is above.

Closing as WONTFIX.