Bug 5533 - Portable ROSA
: Portable ROSA
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-12 18:59 MSD by Andrey Ponomarenko
Modified: 2015-07-07 23:16 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2015-05-12 18:59:57 MSD
Description of problem:

Please add ability to install ROSA in the portable mode. So that one can install it to the external HDD and boot from it on any computer.

The issue is that dracut generates optimized initrd image when installing graphics drivers or kernel updates. This optimized image may not boot on other computer. This is due to hostonly option in the file /etc/dracut.conf.d/50-dracut-rosa.conf. Setting the hostonly option to "no" should fix the issue.

Can we add an optional checkbox in the Installer UI for that?


Version-Release number of selected component (if applicable): R5
Comment 1 Andrey Ponomarenko 2015-07-07 23:16:15 MSD
Fixed in the latest images of ROSA Linux.