Bug 5528 - Bumblebee disables the discrete graphics card in BIOS
: Bumblebee disables the discrete graphics card in BIOS
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Hardware
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Groups for solving hardware issues.
: Eugene Shatokhin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-12 12:30 MSD by Andrey Ponomarenko
Modified: 2015-07-07 23:18 MSD (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2015-05-12 12:30:35 MSD
Description of problem:

The bumblebee package disables the discrete graphics card in BIOS after second reboot, so you can't find it in the output of lspci. The discrete card works fine only for one boot after installation of bumblebee. The card can be fixed by manual reset of BIOS settings. But it will be disabled again on the next boot.

NVIDIA GF108GLM [NVS 5200M] 10de:0dfc 1028:1535

Probe after second reboot (card is disabled): http://hw.rosalinux.ru/index.php?probe=69f72ddbe7
Probe after reset of BIOS (card is enabled): http://hw.rosalinux.ru/index.php?probe=6ef0af095e

The problem is not reproduced on other tested computers with Optimus graphics on board.

Version-Release number of selected component (if applicable): R5


How reproducible: always


Steps to Reproduce:
1. Install Bumblebee (select nvidia driver in XFdrake)
2. Reboot
3. Run discrete card: optirun glxgears
4. Reboot
5. Try to find the discrete card: lspci -vnn | grep NVIDIA
Comment 2 Andrey Ponomarenko 2015-05-12 13:29:35 MSD
Setting TurnCardOffAtExit to false in /etc/bumblebee/bumblebee.conf fixed the issue.

HW Probe: http://hw.rosalinux.ru/index.php?probe=bab3304e66

More info: https://wiki.archlinux.org/index.php/Bumblebee#Enable_NVIDIA_card_during_shutdown
Comment 3 Andrey Ponomarenko 2015-05-12 13:39:06 MSD
The XFdrake should be fixed properly to prevent the card power off.
Comment 4 Andrey Ponomarenko 2015-07-07 23:18:17 MSD
Fixed in the latest version of drakx-kbd-mouse-x11.