Bug 5527 - [UPDATE REQUEST] libass 0.10.0 -> 0.12.1
: [UPDATE REQUEST] libass 0.10.0 -> 0.12.1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-12 10:14 MSD by Andrey Bondrov
Modified: 2015-05-19 11:13 MSD (History)
4 users (show)

See Also:
RPM Package: libass
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2015-05-12 10:14:56 MSD
We need to update libass (ASS/SSA subtitle renderer library), new version is required for MPV update. It also comes with many bugfixes.
Comment 1 Andrey Bondrov 2015-05-12 10:26:40 MSD
libass:
Advisory: "New version 0.12.1"
https://abf.rosalinux.ru/build_lists/2499806
https://abf.rosalinux.ru/build_lists/2499807

We also need to rebuild these officially supported packages with new version of libass (because of libass.so.4 -> libass.so.5 change):

ffmpeg:
Advisory: "New bugfix version 2.5.6, rebuild with libass 0.12.x"
https://abf.rosalinux.ru/build_lists/2500164
https://abf.rosalinux.ru/build_lists/2500165

ffmpeg-restricted:
Advisory: "New bugfix version 2.5.6, rebuild with libass 0.12.x"
https://abf.rosalinux.ru/build_lists/2500166
https://abf.rosalinux.ru/build_lists/2500167

vlc:
Advisory: "New bugfix version 2.1.6, rebuild with libass 0.12.x"
https://abf.rosalinux.ru/build_lists/2500171
https://abf.rosalinux.ru/build_lists/2500172

vlc-restricted:
Advisory: "New bugfix version 2.1.6, rebuild with libass 0.12.x"
https://abf.rosalinux.ru/build_lists/2500173
https://abf.rosalinux.ru/build_lists/2500174

mplayer:
Advisory: "Rebuild with libass 0.12.x"
https://abf.rosalinux.ru/build_lists/2500185
https://abf.rosalinux.ru/build_lists/2500186

mplayer-restricted:
Advisory: "Rebuild with libass 0.12.x"
https://abf.rosalinux.ru/build_lists/2500187
https://abf.rosalinux.ru/build_lists/2500188

gstreamer0.10-plugins-bad:
Advisory: "Rebuild with libass 0.12.x"
https://abf.rosalinux.ru/build_lists/2500189
https://abf.rosalinux.ru/build_lists/2500190

gstreamer0.10-plugins-bad-restricted:
Advisory: "Rebuild with libass 0.12.x"
https://abf.rosalinux.ru/build_lists/2500191
https://abf.rosalinux.ru/build_lists/2500192

gstreamer1.0-plugins-bad:
Advisory: "Rebuild with libass 0.12.x"
https://abf.rosalinux.ru/build_lists/2500193
https://abf.rosalinux.ru/build_lists/2500194

gstreamer1.0-plugins-bad-restricted:
Advisory: "Rebuild with libass 0.12.x"
https://abf.rosalinux.ru/build_lists/2500195
https://abf.rosalinux.ru/build_lists/2500196

After the update is approved we need to rebuild some more packages with new libass (until that they will use libass4/lib64ass4):
1. bino
2. handbrake
3. mpv
4. mythplugins
5. mythtv
6. qmplay2
7. vapoursynth
8. xbmc

I set high priority to this update because it affects (blocks) many packages.
Comment 2 FirstLevel 2015-05-13 17:00:57 MSD
32bit

urpmi vlc gstreamer0.10-plugins-bad , plug all containers and update, launching mplayer and vlc, playing files from http://techslides.com/sample-webm-ogg-and-mp4-video-files-for-html5/ - ok
plug all containers and update, urpmi vlc gstreamer0.10-plugins-bad , launching mplayer and vlc, playing files from http://techslides.com/sample-webm-ogg-and-mp4-video-files-for-html5/ - ok
urpmi gstreamer0.10-libass gstreamer1.0-libass (requires libass5) - ok
Comment 3 FirstLevel 2015-05-13 17:38:38 MSD
64bit

urpmi vlc gstreamer0.10-plugins-bad , plug all containers and update, launching mplayer and vlc, playing files from http://techslides.com/sample-webm-ogg-and-mp4-video-files-for-html5/ - ok
plug all containers and update, urpmi vlc gstreamer0.10-plugins-bad , launching mplayer and vlc, playing files from http://techslides.com/sample-webm-ogg-and-mp4-video-files-for-html5/ - 
urpmi gstreamer0.10-libass gstreamer1.0-libass (requires libass5) - ok
Comment 4 Andrey Ponomarenko 2015-05-13 18:17:42 MSD
ABI changes in libass 0.10 vs 0.12: http://upstream-tracker.org/versions/libass.html
Comment 5 Andrey Bondrov 2015-05-13 18:24:17 MSD
(In reply to comment #4)
> ABI changes in libass 0.10 vs 0.12:
> http://upstream-tracker.org/versions/libass.html

Yes, that's why we rebuild packages that use libass.
Comment 6 Vladimir Potapov 2015-05-14 17:27:31 MSD
The update is sent to expanded testing
**************************************
Comment 7 Vladimir Potapov 2015-05-18 20:49:30 MSD
libass-0.12.1-1
https://abf.rosalinux.ru/build_lists/2499806
https://abf.rosalinux.ru/build_lists/2499807

ffmpeg-2.5.6-1
https://abf.rosalinux.ru/build_lists/2500164
https://abf.rosalinux.ru/build_lists/2500165

ffmpeg-2.5.6-1plf
https://abf.rosalinux.ru/build_lists/2500166
https://abf.rosalinux.ru/build_lists/2500167

vlc-2.1.6-1
https://abf.rosalinux.ru/build_lists/2500171
https://abf.rosalinux.ru/build_lists/2500172

vlc-2.1.6-1plf
https://abf.rosalinux.ru/build_lists/2500173
https://abf.rosalinux.ru/build_lists/2500174

mplayer-1.1.1-2.r37337.5
https://abf.rosalinux.ru/build_lists/2500185
https://abf.rosalinux.ru/build_lists/2500186

mplayer-1.1.1-2.r37337.5plf
https://abf.rosalinux.ru/build_lists/2500187
https://abf.rosalinux.ru/build_lists/2500188


gstreamer0.10-plugins-bad
https://abf.rosalinux.ru/build_lists/2500189
https://abf.rosalinux.ru/build_lists/2500190

gstreamer0.10-plugins-bad-0.10.23-6plf
https://abf.rosalinux.ru/build_lists/2500191
https://abf.rosalinux.ru/build_lists/2500192

gstreamer1.0-plugins-bad-1.2.4-4
https://abf.rosalinux.ru/build_lists/2500193
https://abf.rosalinux.ru/build_lists/2500194

gstreamer1.0-plugins-bad-1.2.4-4plf
https://abf.rosalinux.ru/build_lists/2500195
https://abf.rosalinux.ru/build_lists/2500196

************************* Advisory *************************
libass: New version 0.12.1
ffmpeg, ffmpeg-restricted: New bugfix version 2.5.6, rebuild with libass 0.12.x
vlc, vlc-restricted: New bugfix version 2.1.6, rebuild with libass 0.12.x
mplayer, mplayer-restricted, gstreamer0.10-plugins-bad, gstreamer0.10-plugins-bad-restricted, gstreamer1.0-plugins-bad, gstreamer1.0-plugins-bad-restricted: Rebuild with libass 0.12.x
************************************************************
QA Verified
Comment 8 Andrey Bondrov 2015-05-19 11:13:54 MSD
(In reply to comment #1)
> After the update is approved we need to rebuild some more packages with new
> libass (until that they will use libass4/lib64ass4):
> 1. bino
> 2. handbrake
> 3. mpv
> 4. mythplugins
> 5. mythtv
> 6. qmplay2
> 7. vapoursynth
> 8. xbmc

Done.