Bug 5482 - Stratagus 2.3 released.
: Stratagus 2.3 released.
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-06 02:26 MSD by Zombie Ryushu
Modified: 2015-05-08 15:12 MSD (History)
1 user (show)

See Also:
RPM Package: stratagus
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2015-05-06 02:26:20 MSD
Finally, here comes a new release of Stratagus engine and this is a really major release since 2.2.7.

It adds a lot of new features to the engine and fixes a huge amount of bugs. You may also encounter a new games based on the engine, such as Doom Wars and Wyrmsun.
More information in the changelog.

Wargus has also been updated to version 2.3.
Comment 1 Andrey Bondrov 2015-05-06 11:02:52 MSD
Done, updated both Stratagus and Wargus to 2.3.0.

Wyrmsun looks very good but it's really not user-friendly to build.
Comment 2 Zombie Ryushu 2015-05-08 06:00:34 MSD
This build you have made will not let me start a Single player Campaign because it disables support for GZ Compressed files.
Comment 3 Andrey Bondrov 2015-05-08 13:26:02 MSD
(In reply to comment #2)
> This build you have made will not let me start a Single player Campaign
> because it disables support for GZ Compressed files.

Sounds strange, build log seems to be fine. Can you please provide more info?

1. Do you use official rosa2014.1 packages or rebuild SRPMs for rosa2012.1?
2. Does it happen with wargus or another game?
3. Can you please provide me game data to debug this issue?
Comment 4 Zombie Ryushu 2015-05-08 13:49:23 MSD
I use Rosa 2014.1 now. Its happening with Wargus, after re-extracting with Wartool, I have to gunzip all the Oggs in the music or they sound like Static, and I can play a Multiplayer game alone if it is set to have Single player map that has computer oppoenents, but if I try and play a Single player game, I get an error handling error handler. The Single player map and campaign map is an empty Dialogue box.
Comment 5 Zombie Ryushu 2015-05-08 13:51:04 MSD
Wargus has Game data you can use, for people who want to play Wargus without Official Warcraft II. Install Aleona's tales. then launch stratagus.
Comment 6 Andrey Bondrov 2015-05-08 14:25:13 MSD
(In reply to comment #5)
> Wargus has Game data you can use, for people who want to play Wargus without
> Official Warcraft II. Install Aleona's tales. then launch stratagus.

Aleona's tales looks very bad but works for me.

I remember long time ago I had major issues with running Wargus. I tried many Warcraft 2 archives before I found the one that works. Maybe the issue is not because of wargus itself but because of game data.
Comment 7 Andrey Bondrov 2015-05-08 15:08:22 MSD
(In reply to comment #4)
> I use Rosa 2014.1 now. Its happening with Wargus, after re-extracting with
> Wartool, I have to gunzip all the Oggs in the music or they sound like
> Static, and I can play a Multiplayer game alone if it is set to have Single
> player map that has computer oppoenents, but if I try and play a Single
> player game, I get an error handling error handler. The Single player map
> and campaign map is an empty Dialogue box.

Ok, I found game data and did some testing. It doesn't play videos indeed, but I don't have required files:

Can't open file `videos/logo.ogv'
Can't open file `videos/gameintro.ogv'

It plays music if I put TimGM6mb.sf2 to music/ directory of the game data.

I can play single scenarios and campaigns that I have. The bad thing is that wargus doesn't detect what I have, it just displays all supported campaigns. So when I try to open any campaign I don't have, I'm returned to the main menu without any message.

I don't see any packaging errors with this version, so please report all bugs upstream, I cannot do the job for them. So I mark this bug as closed.
Comment 8 Zombie Ryushu 2015-05-08 15:12:20 MSD
Its something I have caused then. In the past Stratagus has not supported the Battle.net Edition of Warcraft II, and Warcraft II's expansion, beyond the Dark Portal. Stratagus 2.3 is the first version to support extraction of MPQ Files used in that Battle.net edition.