Bug 5449 - FireFox seems to be segfaults
: FireFox seems to be segfaults
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-28 15:45 MSD by Zombie Ryushu
Modified: 2016-09-28 11:32 MSD (History)
2 users (show)

See Also:
RPM Package: firefox
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2015-04-28 15:45:43 MSD
I've got some unusual situations where FireFox has been crashing for unknown reasons. 

NOT SANDBOXED
[fresh 30466] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 30466] [PPB] {fake} ppb_video_capture_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {zilch} ppb_network_monitor_update_network_list
[fresh 30466] [PPB] {zilch} ppb_text_input_interface_set_text_input_type instance=10, type=PP_TEXTINPUT_TYPE_DEV_NONE
[fresh 30466] [PPB] {zilch} ppb_flash_set_instance_always_on_top instance=10, on_top=1
[fresh 30466] [PPB] {fake} ppb_video_capture_close
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 30466] [PPB] {fake} ppb_audio_input_enumerate_devices

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

NOT SANDBOXED
[fresh 31263] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 31263] [PPB] {fake} ppb_video_capture_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {zilch} ppb_network_monitor_update_network_list
[fresh 31263] [PPB] {zilch} ppb_text_input_interface_set_text_input_type instance=10, type=PP_TEXTINPUT_TYPE_DEV_NONE
[fresh 31263] [PPB] {zilch} ppb_flash_set_instance_always_on_top instance=10, on_top=1
[fresh 31263] [PPB] {fake} ppb_video_capture_close
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 31263] [PPB] {fake} ppb_audio_input_enumerate_devices

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

NOT SANDBOXED
[fresh 32484] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 32484] [PPB] {fake} ppb_video_capture_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {zilch} ppb_network_monitor_update_network_list
[fresh 32484] [PPB] {zilch} ppb_text_input_interface_set_text_input_type instance=10, type=PP_TEXTINPUT_TYPE_DEV_NONE
[fresh 32484] [PPB] {zilch} ppb_flash_set_instance_always_on_top instance=10, on_top=1
[fresh 32484] [PPB] {fake} ppb_video_capture_close
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
[fresh 32484] [PPB] {fake} ppb_audio_input_enumerate_devices
Segmentation fault (core dumped)
[NPAPI 32479] ###!!! ABORT: Aborting on channel error.: file /builddir/build/BUILD/mozilla-release/ipc/glue/MessageChannel.cpp, line 1591
[NPAPI 32479] ###!!! ABORT: Aborting on channel error.: file /builddir/build/BUILD/mozilla-release/ipc/glue/MessageChannel.cpp, line 1591
Comment 1 Denis Silakov 2015-05-26 14:39:02 MSD
This is possibly caused by freshplayer plugin. Could you check if the new version (0.2.4) works better?
Comment 2 Zombie Ryushu 2015-05-26 15:21:11 MSD
I'm currently testing the new FreshplayerPlugin.
Comment 3 Zombie Ryushu 2015-07-05 07:08:14 MSD
This is not caused by FreshPlayerPlugin, I've seen similar Crashes with systems only using the NPAPI Flash Plugin.
Comment 4 Zombie Ryushu 2015-07-24 01:09:53 MSD
[fresh 21466] [PPB] {zilch} ppb_network_monitor_update_network_list
[fresh 21466] [PPB] {zilch} ppb_flash_set_instance_always_on_top instance=53, on_top=1
[fresh 21466] [PPB] {zilch} ppb_network_monitor_update_network_list
[fresh 21466] [PPB] {zilch} ppb_flash_set_instance_always_on_top instance=54, on_top=1
[fresh 21466] [PPB] {zilch} ppb_network_monitor_update_network_list
[fresh 21466] [PPB] {zilch} ppb_flash_set_instance_always_on_top instance=55, on_top=1
[fresh 21466] [PPB] {zilch} ppb_network_monitor_update_network_list
[fresh 21466] [PPB] {zilch} ppb_flash_set_instance_always_on_top instance=56, on_top=1
Segmentation fault (core dumped)
[NPAPI 21464] ###!!! ABORT: Aborting on channel error.: file /builddir/build/BUILD/mozilla-release/ipc/glue/MessageChannel.cpp, line 1597
[NPAPI 21464] ###!!! ABORT: Aborting on channel error.: file /builddir/build/BUILD/mozilla-release/ipc/glue/MessageChannel.cpp, line 1597
[
Comment 5 Zombie Ryushu 2015-07-24 01:37:26 MSD
Switching to Thread 0x7fffba6bd700 (LWP 25764)]
0x00007ffff41a5f1d in ?? () from /usr/lib64/firefox-39.0/libxul.so
(gdb) bt
#0  0x00007ffff41a5f1d in ?? () from /usr/lib64/firefox-39.0/libxul.so
#1  0x00007ffff49caf33 in ?? () from /usr/lib64/firefox-39.0/libxul.so
#2  0x00007ffff49cb2c9 in ?? () from /usr/lib64/firefox-39.0/libxul.so
#3  0x00007ffff4944d64 in ?? () from /usr/lib64/firefox-39.0/libxul.so
#4  0x00007ffff494ce58 in ?? () from /usr/lib64/firefox-39.0/libxul.so
#5  0x00007ffff495aff8 in ?? () from /usr/lib64/firefox-39.0/libxul.so
#6  0x00007ffff4943c02 in ?? () from /usr/lib64/firefox-39.0/libxul.so
#7  0x00007ffff3bb25fc in ?? () from /usr/lib64/firefox-39.0/libxul.so
#8  0x00007ffff3bb1e1c in ?? () from /usr/lib64/firefox-39.0/libxul.so
#9  0x00007ffff3bc5f1a in ?? () from /usr/lib64/firefox-39.0/libxul.so
#10 0x00007ffff3d96674 in ?? () from /usr/lib64/firefox-39.0/libxul.so
#11 0x00007ffff3d7aa4d in ?? () from /usr/lib64/firefox-39.0/libxul.so
#12 0x00007ffff3bb2c15 in ?? () from /usr/lib64/firefox-39.0/libxul.so
#13 0x00000030c9028bbc in ?? () from /lib64/libnspr4.so
#14 0x00000030bb606645 in start_thread () from /lib64/libpthread.so.0
#15 0x00000030baafde7d in clone () from /lib64/libc.so.6
Comment 6 Zombie Ryushu 2015-07-24 06:13:44 MSD
(gdb) bt
#0  0x00000030bb60e87f in send () from /lib64/libpthread.so.0
#1  0x00000030c902629d in ?? () from /lib64/libnspr4.so
#2  0x0000003d3ee21f5d in ?? () from /lib64/libssl3.so
#3  0x0000003d3ee12ef4 in ?? () from /lib64/libssl3.so
#4  0x0000003d3ee13533 in ?? () from /lib64/libssl3.so
#5  0x0000003d3ee27c26 in ?? () from /lib64/libssl3.so
#6  0x00007ffff508c495 in nsNSSSocketInfo::CloseSocketAndDestroy (this=0x7fffaf47e080)
    at /usr/src/debug/mozilla-release/security/manager/ssl/src/nsNSSIOLayer.cpp:1073
#7  0x00007ffff508c50c in nsSSLIOLayerClose (fd=0x7fffacf37d30) at /usr/src/debug/mozilla-release/security/manager/ssl/src/nsNSSIOLayer.cpp:1050
#8  0x00007ffff3c1dc4d in nsSocketTransport::ReleaseFD_Locked (this=0x7fff975e9380, fd=<optimized out>)
    at /usr/src/debug/mozilla-release/netwerk/base/nsSocketTransport2.cpp:1685
#9  0x00007ffff3c2070d in nsSocketTransport::OnSocketDetached (this=0x7fff975e9380, fd=<optimized out>)
    at /usr/src/debug/mozilla-release/netwerk/base/nsSocketTransport2.cpp:1948
#10 0x00007ffff3c1dd03 in nsSocketTransportService::DetachSocket (this=this@entry=0x7ffff7db7530, listHead=0x7fffaf57d000, sock=0x7fffaf57d030)
    at /usr/src/debug/mozilla-release/netwerk/base/nsSocketTransportService2.cpp:195
#11 0x00007ffff3c1eb22 in nsSocketTransportService::DoPollIteration (this=this@entry=0x7ffff7db7530, wait=<optimized out>, 
    pollDuration=pollDuration@entry=0x7fffed0fdd30) at /usr/src/debug/mozilla-release/netwerk/base/nsSocketTransportService2.cpp:1051
#12 0x00007ffff3c23181 in nsSocketTransportService::Run (this=0x7ffff7db7530)
    at /usr/src/debug/mozilla-release/netwerk/base/nsSocketTransportService2.cpp:793
#13 0x00007ffff3bb1e1c in nsThread::ProcessNextEvent (this=0x7ffff0cc8270, aMayWait=<optimized out>, aResult=0x7fffed0fde0f)
    at /usr/src/debug/mozilla-release/xpcom/threads/nsThread.cpp:855
#14 0x00007ffff3bc5f1a in NS_ProcessNextEvent (aThread=<optimized out>, aMayWait=<optimized out>)
    at /usr/src/debug/mozilla-release/xpcom/glue/nsThreadUtils.cpp:265
#15 0x00007ffff3d96674 in mozilla::ipc::MessagePumpForNonMainThreads::Run (this=0x7ffff0cc5800, aDelegate=0x7ffff7d93b80)
    at /usr/src/debug/mozilla-release/ipc/glue/MessagePump.cpp:368
#16 0x00007ffff3d7aa4d in RunHandler (this=0x7ffff7d93b80) at /usr/src/debug/mozilla-release/ipc/chromium/src/base/message_loop.cc:226
#17 MessageLoop::Run (this=this@entry=0x7ffff7d93b80) at /usr/src/debug/mozilla-release/ipc/chromium/src/base/message_loop.cc:200
#18 0x00007ffff3bb2c15 in nsThread::ThreadFunc (aArg=0x7ffff0cc8270) at /usr/src/debug/mozilla-release/xpcom/threads/nsThread.cpp:356
#19 0x00000030c9028bbc in ?? () from /lib64/libnspr4.so
#20 0x00000030bb606645 in start_thread () from /lib64/libpthread.so.0
#21 0x00000030baafde7d in clone () from /lib64/libc.so.6
(gdb) bt full
#0  0x00000030bb60e87f in send () from /lib64/libpthread.so.0
No symbol table info available.
#1  0x00000030c902629d in ?? () from /lib64/libnspr4.so
No symbol table info available.
#2  0x0000003d3ee21f5d in ?? () from /lib64/libssl3.so
No symbol table info available.
#3  0x0000003d3ee12ef4 in ?? () from /lib64/libssl3.so
No symbol table info available.
#4  0x0000003d3ee13533 in ?? () from /lib64/libssl3.so
No symbol table info available.
#5  0x0000003d3ee27c26 in ?? () from /lib64/libssl3.so
No symbol table info available.
#6  0x00007ffff508c495 in nsNSSSocketInfo::CloseSocketAndDestroy (this=0x7fffaf47e080)
    at /usr/src/debug/mozilla-release/security/manager/ssl/src/nsNSSIOLayer.cpp:1073
        popped = 0x7fffb02d23d0
        poppedPlaintext = 0x0
        status = <optimized out>
#7  0x00007ffff508c50c in nsSSLIOLayerClose (fd=0x7fffacf37d30) at /usr/src/debug/mozilla-release/security/manager/ssl/src/nsNSSIOLayer.cpp:1050
        locker = {<No data fields>}
        socketInfo = <optimized out>
#8  0x00007ffff3c1dc4d in nsSocketTransport::ReleaseFD_Locked (this=0x7fff975e9380, fd=<optimized out>)
    at /usr/src/debug/mozilla-release/netwerk/base/nsSocketTransport2.cpp:1685
        fd = <optimized out>
        this = 0x7fff975e9380
#9  0x00007ffff3c2070d in nsSocketTransport::OnSocketDetached (this=0x7fff975e9380, fd=<optimized out>)
    at /usr/src/debug/mozilla-release/netwerk/base/nsSocketTransport2.cpp:1948
        lock = {mLock = 0x7fff975e9498}
        secCtrl = {<nsCOMPtr_base> = {mRawPtr = 0x7fffaf47e138}, <No data fields>}
        ourCallbacks = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        ourEventSink = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
#10 0x00007ffff3c1dd03 in nsSocketTransportService::DetachSocket (this=this@entry=0x7ffff7db7530, listHead=0x7fffaf57d000, sock=0x7fffaf57d030)
    at /usr/src/debug/mozilla-release/netwerk/base/nsSocketTransportService2.cpp:195
        event = {<nsCOMPtr_base> = {mRawPtr = 0x7ffff3c1e7b2 <nsSocketTransport::OnSocketReady(PRFileDesc*, short)+174>}, <No data fields>}
#11 0x00007ffff3c1eb22 in nsSocketTransportService::DoPollIteration (this=this@entry=0x7ffff7db7530, wait=<optimized out>, 
    pollDuration=pollDuration@entry=0x7fffed0fdd30) at /usr/src/debug/mozilla-release/netwerk/base/nsSocketTransportService2.cpp:1051
        numberOfOnSocketReadyCalls = <optimized out>
        i = 2
        count = <optimized out>
        pollInterval = 14
        n = 1
#12 0x00007ffff3c23181 in nsSocketTransportService::Run (this=0x7ffff7db7530)
    at /usr/src/debug/mozilla-release/netwerk/base/nsSocketTransportService2.cpp:793
        pendingEvents = false
        goingOffline = <optimized out>
        numberOfPendingEventsLastCycle = 0
        numberOfPendingEvents = <optimized out>
        singlePollDuration = {mValue = 0}
        startOfIteration = {mValue = 0}
        startOfNextIteration = {mValue = 0}
        pollDuration = <optimized out>
        thread = 0x7ffff0cc8270
        threadInt = {<nsCOMPtr_base> = {mRawPtr = 0x7ffff0cc8270}, <No data fields>}
        startOfCycleForLastCycleCalc = <optimized out>
        pollCycleStart = {mValue = 0}
#13 0x00007ffff3bb1e1c in nsThread::ProcessNextEvent (this=0x7ffff0cc8270, aMayWait=<optimized out>, aResult=0x7fffed0fde0f)
    at /usr/src/debug/mozilla-release/xpcom/threads/nsThread.cpp:855
        event = {<nsCOMPtr_base> = {mRawPtr = 0x7ffff7db7548}, <No data fields>}
        reallyWait = <optimized out>
        notifyMainThreadObserver = <optimized out>
---Type <return> to continue, or q <return> to quit---
        obs = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        rv = NS_OK
#14 0x00007ffff3bc5f1a in NS_ProcessNextEvent (aThread=<optimized out>, aMayWait=<optimized out>)
    at /usr/src/debug/mozilla-release/xpcom/glue/nsThreadUtils.cpp:265
        val = true
#15 0x00007ffff3d96674 in mozilla::ipc::MessagePumpForNonMainThreads::Run (this=0x7ffff0cc5800, aDelegate=0x7ffff7d93b80)
    at /usr/src/debug/mozilla-release/ipc/glue/MessagePump.cpp:368
        didWork = <optimized out>
#16 0x00007ffff3d7aa4d in RunHandler (this=0x7ffff7d93b80) at /usr/src/debug/mozilla-release/ipc/chromium/src/base/message_loop.cc:226
No locals.
#17 MessageLoop::Run (this=this@entry=0x7ffff7d93b80) at /usr/src/debug/mozilla-release/ipc/chromium/src/base/message_loop.cc:200
        save_state = {<MessageLoop::RunState> = {run_depth = 1, quit_received = false}, loop_ = 0x7ffff7d93b80, previous_state_ = 0x0}
#18 0x00007ffff3bb2c15 in nsThread::ThreadFunc (aArg=0x7ffff0cc8270) at /usr/src/debug/mozilla-release/xpcom/threads/nsThread.cpp:356
        self = 0x7ffff0cc8270
        event = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
#19 0x00000030c9028bbc in ?? () from /lib64/libnspr4.so
No symbol table info available.
#20 0x00000030bb606645 in start_thread () from /lib64/libpthread.so.0
No symbol table info available.
#21 0x00000030baafde7d in clone () from /lib64/libc.so.6
No symbol table info available.
(gdb) q
A debugging session is active.

        Inferior 1 [process 32053] will be killed.

Quit anyway? (y or n) y
[NPAPI 4644] ###!!! ABORT: Aborting on channel error.: file /builddir/build/BUILD/mozilla-release/ipc/glue/MessageChannel.cpp, line 1597
[NPAPI 4644] ###!!! ABORT: Aborting on channel error.: file /builddir/build/BUILD/mozilla-release/ipc/glue/MessageChannel.cpp, line 1597
Comment 7 Zombie Ryushu 2015-07-29 05:55:11 MSD
Upstream FireFox maintainers say that this problem appears to be caused by memory related issues in ROSA Specific builds. They reccommend that we try and compare results with the Published ROSA Build themselves
Comment 8 Zombie Ryushu 2015-09-14 18:20:42 MSD
This issue is getting more severe.
Comment 9 Zombie Ryushu 2016-09-28 11:32:53 MSD
Not an FireFox issue. NSS issue.