Bug 5435 - No vi/vim installed in the latest R5 images
: No vi/vim installed in the latest R5 images
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-24 13:07 MSD by Andrey Ponomarenko
Modified: 2015-06-07 01:44 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2015-04-24 13:07:20 MSD
Description of problem:

There is no "vi" or "vim" packages installed in the latest R5 images by default.

Checked image: ROSA.FRESH.KDE.R5.10579.b.x86_64.iso

Version-Release number of selected component (if applicable): R5 10579


How reproducible: always


Steps to Reproduce:
1.
2.
3.
Comment 1 Konstantin Vlasov 2015-04-24 15:28:31 MSD
There are no vi or vim packages. vim-minimal or vim-enhanced should be installed. If there are no /bin/vi and /bin/vim files - it's a known problem which happens randomly during the iso image build. We cannot fix this at the moment, just try another image. We also plan to add this check into autotests.
Comment 2 Denis Silakov 2015-06-06 22:54:38 MSD
To be pedantic, I don't think that "wontfix" is a correct resolution:) This would mean that we are not going to include vim in default image. However, all ROSA images have vim packages installed by default (for a long time we had "vim-minimal", not long ago we decided to switch to "vim-enhanced").

And as Konstantin mentioned, if some image doesn't have the "/bin/vim" executable, then this is a sporadic bug of particular image caused by incorrect package installation order during image preparation (since this order can vary in different images). Release images should be free of this problem.
Comment 3 Konstantin Vlasov 2015-06-07 01:44:08 MSD
BTW, the vi/vim autotests were finally added, so autotested images from now on should be fine in this respect.