Bug 5434 - [UPDATE REQUEST] kernel 3.14.39
: [UPDATE REQUEST] kernel 3.14.39
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-24 11:42 MSD by Eugene Shatokhin
Modified: 2015-05-05 13:29 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
sv (769.51 KB, video/webm)
2015-04-24 17:40 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2015-04-24 11:42:04 MSD
Upstream update to version 3.14.39 + our bug fixes.
Comment 1 Eugene Shatokhin 2015-04-24 11:54:49 MSD
Advisory:
The kernel packages were updated to version 3.14.39 that provides lots of fixes all-around. Besides that, the following changes were made:
* Fixed the issues with cpupower (bug #4810).
* Revisited handling of DKMS modules to make it more reliable. That also required to make kernel-<flavour>-devel packages a dependency for the kernel-<flavour> packages.
* Added system architecture in the version of the kernel (bug #4823).
* Removed unneeded files (bug #630).
* Fixed package information (bug #5071).
* Added TSYNC support for seccomp.
* Added many smaller fixes.
In addition, the kernel packages do not update grub configuration themselves now, because the file triggers from grub2 package handle that already.

Build lists:
i586: 
https://abf.io/build_lists/2493064
x86_64:
https://abf.io/build_lists/2493065
Comment 2 Eugene Shatokhin 2015-04-24 12:11:18 MSD
Hints for testing

Please check the following among other things:

1. DKMS
The way DKMS modules (e.g. nvidia*, broadcom-wl, fglrx) are handled when the kernel is installed or removed was rewritten to make it more reliable. 

Please check installation/removal of the kernels and dkms- packages. 
For example, install the proprietary graphics drivers, then install the updates for all kernel flavours (nrj-desktop and nrj-laptop on x64; nrj-desktop, nrj-laptop and their PAE variants on i586). 

See if the proprietary drivers are rebuilt for all these kernels flavours when the kernels are installed and the system boots OK to these.

Please also check the following scenario:
1) install the proprietary drivers (any of)
2) install kernel 3.14.39 (any flavour)
3) remove the kernel and install it again
4) check that the driver has been built and installed and works properly (after reboot).

2. TSYNC
Despite what was written in the news, it is *not* required for Google Chrome. Still, this feature *can* be used by Google Chrome, Chromium, Adobe Flash (and may be others). Please check if there are ant regressions in that software.

For Chrome and Chromium, please try to install and use some extensions, see if the browser crashes.

3. WiFi (ath5k)
If there are systems with Qualcomm/Atheros WiFi chips managed by ath5k driver where the connection was unstable, please see if the situation has improved now.

It is not guaranteed to improve but it may. The new kernel contains some foxes for that.
Comment 3 Vladimir Potapov 2015-04-24 17:40:17 MSD
Created attachment 3917 [details]
sv

Error on XFdrake run
Comment 4 Eugene Shatokhin 2015-04-24 20:56:36 MSD
(In reply to comment #3)
> Created attachment 3917 [details]
> sv
> 
> Error on XFdrake run

This is due to the fix for http://bugs.rosalinux.ru/show_bug.cgi?id=4823 and should be fixed in XFdrake.

Meanwhile, as -devel packages will now be installed anyway, that error message from XFdrake can be safely ignored.
Comment 5 Eugene Shatokhin 2015-04-27 19:54:41 MSD
(In reply to comment #4)
> This is due to the fix for http://bugs.rosalinux.ru/show_bug.cgi?id=4823 and
> should be fixed in XFdrake.

The update for XFdrake fixing this issue is now being prepared. The build lists will be specified below when ready. Please do not publish this kernel update to testing until then.
Comment 6 Andrey Ponomarenko 2015-04-27 20:28:21 MSD
drakx-kbd-mouse-x11 0.120 compatible with this kernel:

x86_64: https://abf.rosalinux.ru/build_lists/2494826
i586: https://abf.rosalinux.ru/build_lists/2494825
Comment 7 Vladimir Potapov 2015-04-27 21:58:37 MSD
The update is sent to expanded testing
***************************************
Comment 8 Vladimir Potapov 2015-05-05 12:44:09 MSD
kernel-3.14.39-4
https://abf.io/build_lists/2493064
https://abf.io/build_lists/2493065
***************************** Advisory *******************************
The kernel packages were updated to version 3.14.39 that provides lots of fixes all-around. Besides that, the following changes were made:
* Fixed the issues with cpupower (bug #4810).
* Revisited handling of DKMS modules to make it more reliable. That also required to make kernel-<flavour>-devel packages a dependency for the kernel-<flavour> packages.
* Added system architecture in the version of the kernel (bug #4823).
* Removed unneeded files (bug #630).
* Fixed package information (bug #5071).
* Added TSYNC support for seccomp.
* Added many smaller fixes.
In addition, the kernel packages do not update grub configuration themselves now, because the file triggers from grub2 package handle that already.
************************************************************************
QA Verified
Comment 9 Denis Silakov 2015-05-05 13:29:00 MSD
Both kernel and XFdrake have been published.