Bug 5432 - "rpmbuild -vv" segfaults on some packages
: "rpmbuild -vv" segfaults on some packages
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-23 18:09 MSD by Denis Silakov
Modified: 2015-05-05 13:51 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
log-rpmbuild.txt (26.51 KB, text/plain)
2015-04-27 15:37 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2015-04-23 18:09:48 MSD
$ rpmbuild -vv -bs dhcp.spec
D: pool fd:     created size 392 limit -1 flags 0
D: pool ds:     created size 232 limit -1 flags 0
D: pool syck:   created size 40 limit -1 flags 0
D: pool ht:     created size 72 limit -1 flags 0
D: pool mire:   created size 136 limit -1 flags 0
D: pool lua:    created size 64 limit -1 flags 0
D: pool ts:     created size 1200 limit -1 flags 0
D: pool spec:   created size 600 limit -1 flags 0
D: pool h:      created size 360 limit -1 flags 0
D: pool pkg:    created size 168 limit -1 flags 0
D: pool luav:   created size 56 limit -1 flags 0
D: pool ctx:    created size 112 limit -1 flags 0
D: pool iob:    created size 48 limit -1 flags 0
Segmentation fault (core dumped)

Backtrace:

(gdb) bt
#0  0x0000003b4c64a17b in vfprintf () from /lib64/libc.so.6
#1  0x0000003b4c70d3f6 in __vsnprintf_chk () from /lib64/libc.so.6
#2  0x0000003521ec9e69 in vsnprintf (__ap=0x7fffffff9a30, 
    __fmt=0x3521623df8 "%s will be satisfied by glibc or it's dependencies, won't add dependency to package\n", __n=8192, 
    __s=0x67ab30 "") at /usr/include/bits/stdio2.h:77
#3  vrpmlog (code=code@entry=7, 
    fmt=fmt@entry=0x3521623df8 "%s will be satisfied by glibc or it's dependencies, won't add dependency to package\n", 
    ap=ap@entry=0x7fffffff9a98) at rpmlog.c:232
#4  0x000000352161d734 in rpmlog (code=code@entry=7, 
    fmt=fmt@entry=0x3521623df8 "%s will be satisfied by glibc or it's dependencies, won't add dependency to package\n")
    at ../rpmio/rpmlog.h:308
#5  0x000000352161dfcd in addReqProv (spec=spec@entry=0x6438a0, h=0x6700b0, tagN=tagN@entry=RPMTAG_REQUIRENAME, 
    N=0x673c00 "/bin/sh", EVR=EVR@entry=0x0, Flags=Flags@entry=768, index=0) at reqprov.c:53
#6  0x000000352161b544 in parseScript (spec=spec@entry=0x6438a0, parsePart=<optimized out>) at parseScript.c:401
Comment 2 Denis Silakov 2015-04-23 19:01:28 MSD
Indeed, our patch is wrong, it forgets to pass a real argument.

Btw, OMV fixed this long time ago:

https://abf.io/openmandriva/rpm/commit/f228f1d08a706916c8d3a477e568b929599e30ec
Comment 3 Denis Silakov 2015-04-24 11:54:05 MSD
Advisory:

Fix segmentation fault in rpmbuild invoked with "-vv" option when reporting dropped requirements on "/bin/sh" and "/sbin/ldconfig".

This update shouldn't affect any rpm tools except rpmbuild.

Build lists:

https://abf.rosalinux.ru/build_lists/2493099
https://abf.rosalinux.ru/build_lists/2493100
Comment 4 FirstLevel 2015-04-27 14:49:36 MSD
(In reply to comment #3)
> Advisory:
> 
> Fix segmentation fault in rpmbuild invoked with "-vv" option when reporting
> dropped requirements on "/bin/sh" and "/sbin/ldconfig".
> 
> This update shouldn't affect any rpm tools except rpmbuild.
> 
> Build lists:
> 
> https://abf.rosalinux.ru/build_lists/2493099
> https://abf.rosalinux.ru/build_lists/2493100

How should we check this? Coud You give test scenario?
Comment 5 Denis Silakov 2015-04-27 14:51:21 MSD
$ git clone https://abf.io/import/dhcp.git -b rosa2014.1
$ cd dhcp
$ rpmbuild -vv -bs dhcp.spec
Comment 6 FirstLevel 2015-04-27 15:37:35 MSD
(In reply to comment #5)
> $ git clone https://abf.io/import/dhcp.git -b rosa2014.1
> $ cd dhcp
> $ rpmbuild -vv -bs dhcp.spec

32bit
urpmi librpm-devel librpm-static-devel perl-RPM  rpm-apidocs rpm-build rpm-squirrelembed rpm-tclembed & plug container & update - ok
plug container & update & urpmi librpm-devel librpm-static-devel perl-RPM  rpm-apidocs rpm-build rpm-squirrelembed rpm-tclembed  - ok


64bit
urpmi lib64rpm-devel lib64rpm-static-devel perl-RPM  rpm-apidocs rpm-build rpm-squirrelembed rpm-tclembed & plug container & update - 
plug container & update & urpmi lib64rpm-devel lib64rpm-static-devel perl-RPM  rpm-apidocs rpm-build rpm-squirrelembed rpm-tclembed - 


But I have no issus with Segmentation fault neither for old, nor for new version.
See attachment. log-rpmbuild.txt
Comment 7 FirstLevel 2015-04-27 15:37:50 MSD
Created attachment 3923 [details]
log-rpmbuild.txt
Comment 8 Denis Silakov 2015-04-27 15:40:25 MSD
Please create /home/sergei32/rpmbuild/SOURCES folder first.
Comment 9 FirstLevel 2015-04-27 16:08:23 MSD
(In reply to comment #8)
> Please create /home/sergei32/rpmbuild/SOURCES folder first.

Segfault is presented

[sergei32@r5-32 dhcp (rosa2014.1)]$ rpmbuild -vv -bs dhcp.spec
D: pool fd:     created size 212 limit -1 flags 0
D: pool ds:     created size 128 limit -1 flags 0
D: pool syck:   created size 20 limit -1 flags 0
D: pool ht:     created size 36 limit -1 flags 0
D: pool mire:   created size 88 limit -1 flags 0
D: pool lua:    created size 36 limit -1 flags 0
D: pool ts:     created size 724 limit -1 flags 0
D: pool spec:   created size 440 limit -1 flags 0
D: pool h:      created size 220 limit -1 flags 0
D: pool pkg:    created size 88 limit -1 flags 0
D: pool luav:   created size 40 limit -1 flags 0
D: pool ctx:    created size 60 limit -1 flags 0
D: pool iob:    created size 24 limit -1 flags 0
Fetching(Patch18): dhcp-4.3.0-64_bit_lease_parse.patch
Fetching(Patch17): dhcp-4.2.0-add_timeout_when_NULL.patch
Fetching(Patch15): dhcp-4.2.2-missing-ipv6-not-fatal.patch
Fetching(Patch7): dhcp-4.2.0-default-requested-options.patch
Fetching(Patch103): dhcp-4.2.5-P1-man.patch
Fetching(Patch102): dhcp-4.1.1-prevent_wireless_deassociation.patch
Fetching(Patch100): dhcp-4.2.2-ifup.patch
Fetching(Source19): dhcrelay.tmpfiles
Fetching(Source18): dhclient.tmpfiles
Fetching(Source17): dhcpd.tmpfiles
Fetching(Source16): dhcrelay.service
Fetching(Source14): dhcpd6.service
Fetching(Source12): dhcpd.service
Fetching(Source10): draft-ietf-dhc-ldap-schema-01.txt
Fetching(Source9): dhclient-exit-hooks
Fetching(Source8): dhcpd-chroot.sh
Fetching(Source7): dhcpreport.pl
Fetching(Source4): dhcp-dynamic-dns-examples.tar.bz2
--2015-04-27 15:07:35--  http://dhcp-dynamic-dns-examples.tar.bz2/
Распознаётся dhcp-dynamic-dns-examples.tar.bz2 (dhcp-dynamic-dns-examples.tar.bz2)… ошибка: Имя или служба не известны.
wget: не удаётся разрешить адрес «dhcp-dynamic-dns-examples.tar.bz2»
Ошибка сегментирования (слепок снят)
[sergei32@r5-32 dhcp (rosa2014.1)]$ rpm -qa | grep rpm
rpm-helper-0.24.1-4-rosa2014.1.noarch
mdv-rpm-summary-0.9.4-7-rosa2014.1.noarch
kcm-rpmdrake-update-1.0-7-rosa2014.1.noarch
kcm-rpmdrake-sources-1.0-11-rosa2014.1.noarch
kcm-rpmdrake-1.0-7-rosa2014.1.noarch
rpmstats-0.7-5-rosa2014.1.i586
python-rpm5utils-2.3.1-1-rosa2014.1.noarch
urpm-tools-2.3.1-1-rosa2014.1.noarch
urpmi-7.32.3-41-rosa2014.1.noarch
gurpmi-7.32.3-41-rosa2014.1.noarch
rpmdrake-5.26.12-48-rosa2014.1.noarch
rpm-mandriva-setup-build-1.140-7-rosa2014.1.noarch
rpmlint-rosa-policy-0.3.24-1-rosa2014.1.noarch
rpmlint-1.5-9-rosa2014.1.noarch
librpm5.4-5.4.10-58-rosa2014.1.i586
rpm-5.4.10-58-rosa2014.1.i586
librpm-devel-5.4.10-58-rosa2014.1.i586
python-rpm-5.4.10-58-rosa2014.1.i586
librpm-static-devel-5.4.10-58-rosa2014.1.i586
rpm-build-5.4.10-58-rosa2014.1.i586
rpm-apidocs-5.4.10-58-rosa2014.1.noarch
rpm-tclembed-5.4.10-58-rosa2014.1.i586
rpm-squirrelembed-5.4.10-58-rosa2014.1.i586
[sergei32@r5-32 dhcp (rosa2014.1)]$
Comment 10 Denis Silakov 2015-04-27 16:21:04 MSD
This is another kind segfault.

Please install abfcc and launch "abf fetch" inside the dhcp folder rr download files specified in .abf.yml file from file-store.rosalinux.ru manually and put them to ~/rpmbuild/SOURCES.
Comment 11 FirstLevel 2015-04-27 16:37:17 MSD
(In reply to comment #10)
> This is another kind segfault.
> 
> Please install abfcc and launch "abf fetch" inside the dhcp folder rr
> download files specified in .abf.yml file from file-store.rosalinux.ru
> manually and put them to ~/rpmbuild/SOURCES.

Please give more clear instruction.
Comment 12 Denis Silakov 2015-04-27 16:40:16 MSD
/* inside dhcp folder */

$ urpmi abfcc
$ abf fetch
$ cp * ~/rpmbuild/SOURCES/
$ rpmbuild -vv -bs *spec
Comment 13 FirstLevel 2015-04-27 17:07:01 MSD
> /* inside dhcp folder */
> 
> $ urpmi abfcc
> $ abf fetch
> $ cp * ~/rpmbuild/SOURCES/
> $ rpmbuild -vv -bs *spec

For this scenario I have no segfaul for old version:
[sergei32@r5-32 dhcp (rosa2014.1)]$ rpmbuild -vv -bs *spec
D: pool fd:     created size 212 limit -1 flags 0
D: pool ds:     created size 128 limit -1 flags 0
D: pool syck:   created size 20 limit -1 flags 0
D: pool ht:     created size 36 limit -1 flags 0
D: pool mire:   created size 88 limit -1 flags 0
D: pool lua:    created size 36 limit -1 flags 0
D: pool ts:     created size 724 limit -1 flags 0
D: pool spec:   created size 440 limit -1 flags 0
D: pool h:      created size 220 limit -1 flags 0
D: pool pkg:    created size 88 limit -1 flags 0
D: pool luav:   created size 40 limit -1 flags 0
D: pool ctx:    created size 60 limit -1 flags 0
D: pool iob:    created size 24 limit -1 flags 0
D: created directory(s) /home/sergei32/rpmbuild/BUILD mode 0755
D: (null) will be satisfied by glibc or it's dependencies, won't add dependency to package
D: (null) will be satisfied by glibc or it's dependencies, won't add dependency to package
D: (null) will be satisfied by glibc or it's dependencies, won't add dependency to package
D: (null) will be satisfied by glibc or it's dependencies, won't add dependency to package
D: (null) will be satisfied by glibc or it's dependencies, won't add dependency to package
D: (null) will be satisfied by glibc or it's dependencies, won't add dependency to package
D: (null) will be satisfied by glibc or it's dependencies, won't add dependency to package
D: pool dig:    created size 240 limit -1 flags 0
D: pool sx:     created size 20 limit -1 flags 0
D: pool fi:     created size 320 limit -1 flags 0
D: created directory(s) /home/sergei32/rpmbuild/SRPMS mode 0755
D: fini      100644  1 (   0,   0)        1382 /home/sergei32/rpmbuild/SOURCES/dhclient-exit-hooks 
D: fini      100644  1 (   0,   0)          30 /home/sergei32/rpmbuild/SOURCES/dhclient.tmpfiles 
D: fini      100644  1 (   0,   0)        1606 /home/sergei32/rpmbuild/SOURCES/dhcp-4.1.1-prevent_wireless_deassociation.patch 
D: fini      100644  1 (   0,   0)         497 /home/sergei32/rpmbuild/SOURCES/dhcp-4.2.0-add_timeout_when_NULL.patch 
D: fini      100644  1 (   0,   0)        1542 /home/sergei32/rpmbuild/SOURCES/dhcp-4.2.0-default-requested-options.patch 
D: fini      100644  1 (   0,   0)        5702 /home/sergei32/rpmbuild/SOURCES/dhcp-4.2.2-ifup.patch 
D: fini      100644  1 (   0,   0)        1055 /home/sergei32/rpmbuild/SOURCES/dhcp-4.2.2-missing-ipv6-not-fatal.patch 
D: fini      100644  1 (   0,   0)        1339 /home/sergei32/rpmbuild/SOURCES/dhcp-4.2.5-P1-man.patch 
D: fini      100644  1 (   0,   0)        2348 /home/sergei32/rpmbuild/SOURCES/dhcp-4.3.0-64_bit_lease_parse.patch 
D: fini      100644  1 (   0,   0)     9230340 /home/sergei32/rpmbuild/SOURCES/dhcp-4.3.2.tar.gz 
D: fini      100644  1 (   0,   0)         486 /home/sergei32/rpmbuild/SOURCES/dhcp-4.3.2.tar.gz.sha512.asc 
D: fini      100644  1 (   0,   0)        8605 /home/sergei32/rpmbuild/SOURCES/dhcp-dynamic-dns-examples.tar.bz2 
D: fini      100644  1 (   0,   0)       12786 /home/sergei32/dhcp/dhcp.spec 
D: fini      100644  1 (   0,   0)        5632 /home/sergei32/rpmbuild/SOURCES/dhcpd-chroot.sh 
D: fini      100644  1 (   0,   0)         574 /home/sergei32/rpmbuild/SOURCES/dhcpd.conf 
D: fini      100644  1 (   0,   0)         397 /home/sergei32/rpmbuild/SOURCES/dhcpd.service 
D: fini      100644  1 (   0,   0)          27 /home/sergei32/rpmbuild/SOURCES/dhcpd.tmpfiles 
D: fini      100644  1 (   0,   0)         387 /home/sergei32/rpmbuild/SOURCES/dhcpd6.service 
D: fini      100644  1 (   0,   0)        8265 /home/sergei32/rpmbuild/SOURCES/dhcpreport.pl 
D: fini      100644  1 (   0,   0)         222 /home/sergei32/rpmbuild/SOURCES/dhcrelay.service 
D: fini      100644  1 (   0,   0)          30 /home/sergei32/rpmbuild/SOURCES/dhcrelay.tmpfiles 
D: fini      100644  1 (   0,   0)       41765 /home/sergei32/rpmbuild/SOURCES/draft-ietf-dhc-ldap-schema-01.txt 
GZDIO:      12 writes,  9328164 total bytes in 0.835751 secs
D: pool tsi:    created size 28 limit -1 flags 0
D: Signature: size(920)+pad(0)
Записан: /home/sergei32/rpmbuild/SRPMS/dhcp-4.3.2-7.src.rpm
Executing "/usr/bin/rpmlint -T -f /home/sergei32/rpmbuild/SOURCES/dhcp.rpmlintrc /home/sergei32/rpmbuild/SRPMS/dhcp-4.3.2-7.src.rpm":
dhcp.src: W: name-repeated-in-summary C DHCP

dhcp.src:95: W: mixed-use-of-spaces-and-tabs (spaces: line 95, tab: line 1)

dhcp.src:277: W: macro-in-comment %{_sysconfdir}

dhcp.src:277: W: macro-in-comment %{name}

1 packages and 0 specfiles checked; 0 errors, 4 warnings.
D: pool pkg:    reused 0, alloc'd 10, free'd 10 items.
D: pool spec:   reused 0, alloc'd 1, free'd 1 items.
D: pool tsi:    reused 3, alloc'd 1, free'd 1 items.
D: pool ts:     reused 0, alloc'd 2, free'd 2 items.
D: pool ds:     reused 50, alloc'd 11, free'd 11 items.
D: pool fi:     reused 0, alloc'd 1, free'd 1 items.
D: pool h:      reused 3, alloc'd 13, free'd 13 items.
D: pool luav:   reused 20, alloc'd 1, free'd 1 items.
D: pool lua:    reused 0, alloc'd 1, free'd 1 items.
D: pool sx:     reused 0, alloc'd 1, free'd 1 items.
D: pool mire:   reused 4, alloc'd 2, free'd 2 items.
D: pool ht:     reused 0, alloc'd 25, free'd 25 items.
D: pool ctx:    reused 25, alloc'd 2, free'd 2 items.
D: pool syck:   reused 0, alloc'd 1, free'd 1 items.
D: pool iob:    reused 20, alloc'd 13, free'd 13 items.
D: pool dig:    reused 0, alloc'd 2, free'd 2 items.
D: pool fd:     reused 67, alloc'd 4, free'd 4 items.
D: exit code: 0
[sergei32@r5-32 dhcp (rosa2014.1)]$ rpm -qa | grep rpm
rpm-helper-0.24.1-4-rosa2014.1.noarch
mdv-rpm-summary-0.9.4-7-rosa2014.1.noarch
kcm-rpmdrake-update-1.0-7-rosa2014.1.noarch
kcm-rpmdrake-sources-1.0-11-rosa2014.1.noarch
kcm-rpmdrake-1.0-7-rosa2014.1.noarch
rpmstats-0.7-5-rosa2014.1.i586
python-rpm5utils-2.3.1-1-rosa2014.1.noarch
urpm-tools-2.3.1-1-rosa2014.1.noarch
librpm5.4-5.4.10-56-rosa2014.1.i586
rpm-5.4.10-56-rosa2014.1.i586
python-rpm-5.4.10-56-rosa2014.1.i586
urpmi-7.32.3-41-rosa2014.1.noarch
gurpmi-7.32.3-41-rosa2014.1.noarch
rpmdrake-5.26.12-48-rosa2014.1.noarch
rpm-mandriva-setup-build-1.140-7-rosa2014.1.noarch
rpm-tclembed-5.4.10-56-rosa2014.1.i586
rpm-apidocs-5.4.10-56-rosa2014.1.noarch
rpmlint-rosa-policy-0.3.24-1-rosa2014.1.noarch
rpmlint-1.5-9-rosa2014.1.noarch
rpm-build-5.4.10-56-rosa2014.1.i586
rpm-squirrelembed-5.4.10-56-rosa2014.1.i586
librpm-devel-5.4.10-56-rosa2014.1.i586
librpm-static-devel-5.4.10-56-rosa2014.1.i586
mock-urpm-1.3.9-1-rosa2014.1.noarch
[sergei32@r5-32 dhcp (rosa2014.1)]$
Comment 14 Denis Silakov 2015-04-27 17:08:51 MSD
This is likely because you use 32bit system, while we observed this bug in 64bit one.

Unfortunately, I don't know reproducer for 32bit OS...
Comment 15 FirstLevel 2015-04-27 17:35:58 MSD
(In reply to comment #14)
> This is likely because you use 32bit system, while we observed this bug in
> 64bit one.
> 
> Unfortunately, I don't know reproducer for 32bit OS...

Ok. Bug is solved for 64bit

[sergei64@r5-64 dhcp (rosa2014.1)]$ rpmbuild -vv -bs 
D: pool fd:     created size 392 limit -1 flags 0
D: pool ds:     created size 232 limit -1 flags 0
D: pool syck:   created size 40 limit -1 flags 0
D: pool ht:     created size 72 limit -1 flags 0
D: pool mire:   created size 136 limit -1 flags 0
D: pool lua:    created size 64 limit -1 flags 0
D: pool ts:     created size 1200 limit -1 flags 0
rpmbuild: не задан файл спецификации для сборки пакета
[sergei64@r5-64 dhcp (rosa2014.1)]$ rpmbuild -vv -bs *spec
D: pool fd:     created size 392 limit -1 flags 0
D: pool ds:     created size 232 limit -1 flags 0
D: pool syck:   created size 40 limit -1 flags 0
D: pool ht:     created size 72 limit -1 flags 0
D: pool mire:   created size 136 limit -1 flags 0
D: pool lua:    created size 64 limit -1 flags 0
D: pool ts:     created size 1200 limit -1 flags 0
D: pool spec:   created size 600 limit -1 flags 0
D: pool h:      created size 360 limit -1 flags 0
D: pool pkg:    created size 168 limit -1 flags 0
D: pool luav:   created size 56 limit -1 flags 0
D: pool ctx:    created size 112 limit -1 flags 0
D: pool iob:    created size 48 limit -1 flags 0
D: created directory(s) /home/sergei64/rpmbuild/BUILD mode 0755
D: /bin/sh will be satisfied by glibc or it's dependencies, won't add dependency to package
D: /bin/sh will be satisfied by glibc or it's dependencies, won't add dependency to package
D: /bin/sh will be satisfied by glibc or it's dependencies, won't add dependency to package
D: /bin/sh will be satisfied by glibc or it's dependencies, won't add dependency to package
D: /bin/sh will be satisfied by glibc or it's dependencies, won't add dependency to package
D: /bin/sh will be satisfied by glibc or it's dependencies, won't add dependency to package
D: /bin/sh will be satisfied by glibc or it's dependencies, won't add dependency to package
D: pool dig:    created size 408 limit -1 flags 0
D: pool sx:     created size 40 limit -1 flags 0
D: pool fi:     created size 560 limit -1 flags 0
D: created directory(s) /home/sergei64/rpmbuild/SRPMS mode 0755
D: fini      100644  1 (   0,   0)        1382 /home/sergei64/rpmbuild/SOURCES/dhclient-exit-hooks 
D: fini      100644  1 (   0,   0)          30 /home/sergei64/rpmbuild/SOURCES/dhclient.tmpfiles 
D: fini      100644  1 (   0,   0)        1606 /home/sergei64/rpmbuild/SOURCES/dhcp-4.1.1-prevent_wireless_deassociation.patch 
D: fini      100644  1 (   0,   0)         497 /home/sergei64/rpmbuild/SOURCES/dhcp-4.2.0-add_timeout_when_NULL.patch 
D: fini      100644  1 (   0,   0)        1542 /home/sergei64/rpmbuild/SOURCES/dhcp-4.2.0-default-requested-options.patch 
D: fini      100644  1 (   0,   0)        5702 /home/sergei64/rpmbuild/SOURCES/dhcp-4.2.2-ifup.patch 
D: fini      100644  1 (   0,   0)        1055 /home/sergei64/rpmbuild/SOURCES/dhcp-4.2.2-missing-ipv6-not-fatal.patch 
D: fini      100644  1 (   0,   0)        1339 /home/sergei64/rpmbuild/SOURCES/dhcp-4.2.5-P1-man.patch 
D: fini      100644  1 (   0,   0)        2348 /home/sergei64/rpmbuild/SOURCES/dhcp-4.3.0-64_bit_lease_parse.patch 
D: fini      100644  1 (   0,   0)     9230340 /home/sergei64/rpmbuild/SOURCES/dhcp-4.3.2.tar.gz 
D: fini      100644  1 (   0,   0)         486 /home/sergei64/rpmbuild/SOURCES/dhcp-4.3.2.tar.gz.sha512.asc 
D: fini      100644  1 (   0,   0)        8605 /home/sergei64/rpmbuild/SOURCES/dhcp-dynamic-dns-examples.tar.bz2 
D: fini      100644  1 (   0,   0)       12786 /home/sergei64/dhcp/dhcp.spec 
D: fini      100644  1 (   0,   0)        5632 /home/sergei64/rpmbuild/SOURCES/dhcpd-chroot.sh 
D: fini      100644  1 (   0,   0)         574 /home/sergei64/rpmbuild/SOURCES/dhcpd.conf 
D: fini      100644  1 (   0,   0)         397 /home/sergei64/rpmbuild/SOURCES/dhcpd.service 
D: fini      100644  1 (   0,   0)          27 /home/sergei64/rpmbuild/SOURCES/dhcpd.tmpfiles 
D: fini      100644  1 (   0,   0)         387 /home/sergei64/rpmbuild/SOURCES/dhcpd6.service 
D: fini      100644  1 (   0,   0)        8265 /home/sergei64/rpmbuild/SOURCES/dhcpreport.pl 
D: fini      100644  1 (   0,   0)         222 /home/sergei64/rpmbuild/SOURCES/dhcrelay.service 
D: fini      100644  1 (   0,   0)          30 /home/sergei64/rpmbuild/SOURCES/dhcrelay.tmpfiles 
D: fini      100644  1 (   0,   0)       41765 /home/sergei64/rpmbuild/SOURCES/draft-ietf-dhc-ldap-schema-01.txt 
GZDIO:      12 writes,  9328164 total bytes in 0.749627 secs
D: pool tsi:    created size 48 limit -1 flags 0
D: Signature: size(920)+pad(0)
Записан: /home/sergei64/rpmbuild/SRPMS/dhcp-4.3.2-7.src.rpm
Executing "/usr/bin/rpmlint -T -f /home/sergei64/rpmbuild/SOURCES/dhcp.rpmlintrc /home/sergei64/rpmbuild/SRPMS/dhcp-4.3.2-7.src.rpm":
dhcp.src: W: name-repeated-in-summary C DHCP

dhcp.src:95: W: mixed-use-of-spaces-and-tabs (spaces: line 95, tab: line 1)

dhcp.src:277: W: macro-in-comment %{_sysconfdir}

dhcp.src:277: W: macro-in-comment %{name}

1 packages and 0 specfiles checked; 0 errors, 4 warnings.
D: pool pkg:    reused 0, alloc'd 10, free'd 10 items.
D: pool spec:   reused 0, alloc'd 1, free'd 1 items.
D: pool tsi:    reused 3, alloc'd 1, free'd 1 items.
D: pool ts:     reused 0, alloc'd 2, free'd 2 items.
D: pool ds:     reused 55, alloc'd 11, free'd 11 items.
D: pool fi:     reused 0, alloc'd 1, free'd 1 items.
D: pool h:      reused 3, alloc'd 13, free'd 13 items.
D: pool luav:   reused 20, alloc'd 1, free'd 1 items.
D: pool lua:    reused 0, alloc'd 1, free'd 1 items.
D: pool sx:     reused 0, alloc'd 1, free'd 1 items.
D: pool mire:   reused 4, alloc'd 2, free'd 2 items.
D: pool ht:     reused 0, alloc'd 25, free'd 25 items.
D: pool ctx:    reused 25, alloc'd 2, free'd 2 items.
D: pool syck:   reused 0, alloc'd 1, free'd 1 items.
D: pool iob:    reused 20, alloc'd 13, free'd 13 items.
D: pool dig:    reused 0, alloc'd 2, free'd 2 items.
D: pool fd:     reused 67, alloc'd 4, free'd 4 items.
D: exit code: 0
[sergei64@r5-64 dhcp (rosa2014.1)]$
Comment 16 Vladimir Potapov 2015-04-28 13:17:44 MSD
The update is sent to expanded testing
***************************************
Comment 17 Vladimir Potapov 2015-05-05 13:30:58 MSD
rpm-5.4.10-58

https://abf.rosalinux.ru/build_lists/2493099
https://abf.rosalinux.ru/build_lists/2493100
************************* Advisory ***************************
Fix segmentation fault in rpmbuild invoked with "-vv" option when reporting dropped requirements on "/bin/sh" and "/sbin/ldconfig".
**************************************************************
QA Verified