Bug 5431 - php-xcache is having conflicts with php-apc
: php-xcache is having conflicts with php-apc
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: symbianflo
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-23 14:26 MSD by Zombie Ryushu
Modified: 2015-04-24 16:28 MSD (History)
2 users (show)

See Also:
RPM Package: php-xcache
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2015-04-23 14:26:21 MSD
php-xcache is having conflicts with php-apc creating errors like:

php-ZendFramework-Cache-Backend-Apc-1.12.9-1-rosa2014.1.noarch
 (due to missing php-apc)
php-apc-3.1.15-3-rosa2014.1.x86_64
 (due to conflicts with php-xcache-3.1.0-7-rosa2014.1.x86_64)
And attempting to uninstall ownCloud.
Comment 1 Denis Silakov 2015-04-23 14:39:34 MSD
Let's ask symbianflo for this.

Conflicts between these php modules (xcache, apc, eaccelerator, etc.) are introduced intentionally (since they are known to be either incompatible or to cause serious problems if installed together) and are set in spec files, e.g.:

https://abf.io/import/php-xcache/blob/rosa2014.1/php-xcache.spec#lc-17

So if owncloud requires some caching mechanism, then we can add some additional abstract dependency which will be provided by php-xcache|php-apc and will be required by the owncloud package.
Comment 2 Zombie Ryushu 2015-04-23 16:38:10 MSD
As long as php-apc is installed ownCloud works.
Comment 3 symbianflo 2015-04-23 20:05:29 MSD
(In reply to comment #1)
> Let's ask symbianflo for this.
> 
> Conflicts between these php modules (xcache, apc, eaccelerator, etc.) are
> introduced intentionally (since they are known to be either incompatible or
> to cause serious problems if installed together) and are set in spec files,
> e.g.:
> 
> https://abf.io/import/php-xcache/blob/rosa2014.1/php-xcache.spec#lc-17
> 
> So if owncloud requires some caching mechanism, then we can add some
> additional abstract dependency which will be provided by php-xcache|php-apc
> and will be required by the owncloud package.

Yes , cached php feature is optional for ssh tunneling ( actually is 3.rd party
community ) in owncloud , so I had to add php-xcache as suggested, maybe 
we can renounce to this optional , and keep php-apc, witch , BTW has to be updated 
because is being obsoleted by php-apcu, the problem is that owncloud main server 
needs php-apc, so this has to remain as Required.
Suggested shouldn't stop the install, hmmmm ok I'll drop php-xcache and rebuild it ,
thanks for your report.
Comment 4 Denis Silakov 2015-04-24 16:28:43 MSD
Should be fine now.