Bug 5418 - [UPDATE REQUEST] nvidia-current 349.16
: [UPDATE REQUEST] nvidia-current 349.16
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Low normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-20 17:00 MSD by Eugene Shatokhin
Modified: 2015-04-27 13:04 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2015-04-20 17:00:52 MSD
Upstream update to version 349.16. 

As before, nvidia-current is not recommended for everyday use, but can be used for testing, debugging and when the drivers suggested by XFdrake do not support the given GPU yet.

The driver only supports NVidia GeForce GTX 400 series or newer GPUs.
Comment 1 Eugene Shatokhin 2015-04-20 17:06:59 MSD
Advisory:
nvidia-current was updated to version 349.16. Most significant changes:
* Added support for the following GPUs: Quadro K1200, Quadro M6000, GeForce 920M, GeForce 930A, GeForce 930M, GeForce 940M, GeForce GTX 950M, GeForce GTX 960M, GeForce GTX TITAN X
* Added support for G-SYNC monitors when used together with non-G-SYNC monitors.
* Added support for lossless H.264/AVC video streams to VDPAU.
* Added support for VDPAU Feature Set F to the NVIDIA VDPAU driver.
* Added nvidia-settings commandline support to query the current and targeted GPU fan speed.
* Added support for YUV 4:2:0 compression to enable HDMI 2.0 4K@60Hz modes.
* Bug fixes.
Besides, the driver will now be built and installed for *all* kernels available in the user's system when the package is installed rather than for the current one only. This should help with the bugs like #5353.

Build lists:
i586:
https://abf.io/build_lists/2491538
x86_64:
https://abf.io/build_lists/2491539
Comment 2 Eugene Shatokhin 2015-04-20 17:12:00 MSD
How to test
See http://bugs.rosalinux.ru/show_bug.cgi?id=5140#c2

Other notes
Because the driver is now built for each kernel available in the user's system (the kernels without development files are skipped) when the packages are installed, the installation may take longer than before. Still, this might help with the problems like #5353. 

If installation for all kernels works OK for nvidia-current, we may use the same technique in the next updates of other dkms-packages as well.
Comment 3 Vladimir Potapov 2015-04-22 15:58:06 MSD
The update is sent to expanded testing
**************************************
Comment 4 Vladimir Potapov 2015-04-27 10:13:32 MSD
nvidia-current-349.16-1
https://abf.io/build_lists/2491538
https://abf.io/build_lists/2491539
***************************** Advisory *******************************
nvidia-current was updated to version 349.16. Most significant changes:
* Added support for the following GPUs: Quadro K1200, Quadro M6000, GeForce 920M, GeForce 930A, GeForce 930M, GeForce 940M, GeForce GTX 950M, GeForce GTX 960M, GeForce GTX TITAN X
* Added support for G-SYNC monitors when used together with non-G-SYNC monitors.
* Added support for lossless H.264/AVC video streams to VDPAU.
* Added support for VDPAU Feature Set F to the NVIDIA VDPAU driver.
* Added nvidia-settings commandline support to query the current and targeted GPU fan speed.
* Added support for YUV 4:2:0 compression to enable HDMI 2.0 4K@60Hz modes.
* Bug fixes.
Besides, the driver will now be built and installed for *all* kernels available in the user's system when the package is installed rather than for the current one only. This should help with the bugs like #5353.
*********************************************************************
QA Verified