Bug 5410 - [UPDATE REQUEST] rosa-imagewriter-2.6.0.0-3
: [UPDATE REQUEST] rosa-imagewriter-2.6.0.0-3
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-19 17:30 MSD by Konstantin Vlasov
Modified: 2015-05-12 19:24 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
konstantin.vlasov: published+


Attachments
old.jpg (75.45 KB, image/jpeg)
2015-04-23 17:45 MSD, FirstLevel
Details
new.jpg (94.50 KB, image/jpeg)
2015-04-23 17:46 MSD, FirstLevel
Details
sv (4.19 MB, video/webm)
2015-04-24 05:19 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2015-04-19 17:30:11 MSD
Update with various improvements.
Comment 1 Konstantin Vlasov 2015-04-19 17:32:59 MSD
https://abf.rosalinux.ru/build_lists/2490697
https://abf.rosalinux.ru/build_lists/2490698

Advisory:
* Added the "Clear" button for destroying partition table on the USB flash disk and allowing OS to see its full capacity.
* Path to ISO image can be passed via command line.
* Application added to the Dolphin context menu in KDE, and in the list of associations in GNOME.
* Various minor fixes and improvements.
Comment 2 FirstLevel 2015-04-23 17:45:25 MSD
Some strange things.
1. I see that password request is different for old version and new version. See attachment.
2. While launching from konsole I see such strings for new version

[sergei32@r5-32 ~]$ rosa-imagewriter 
kdesu(10329) startApp: Daemon not safe (not sgid), not using it.
 

For old version I don't see such strings
Comment 3 FirstLevel 2015-04-23 17:45:53 MSD
Created attachment 3913 [details]
old.jpg
Comment 4 FirstLevel 2015-04-23 17:46:28 MSD
Created attachment 3914 [details]
new.jpg
Comment 5 Konstantin Vlasov 2015-04-23 18:55:42 MSD
It's caused by switching from consolehelper elevation mechanism to direct launch of kdesu/gksu, so that portable versions can be launched directly, without using an additional shell script.
Comment 6 Vladimir Potapov 2015-04-24 05:19:21 MSD
Created attachment 3916 [details]
sv

i586 version on i586 don't work correct (see video sv)
Comment 7 Vladimir Potapov 2015-04-24 05:20:05 MSD
i586 version don't work correct (see video sv)
***********************************************
QA Denied
Comment 8 Konstantin Vlasov 2015-04-29 22:18:41 MSD
The problem with incorrect Clear function with selected image file will be fixed soon.

The second problem I cannot reproduce. Please, provide hw-probe for that machine.
Comment 9 Vladimir Potapov 2015-04-30 03:32:30 MSD
Second issue reproduce only on i586 system
The probe created after the issue
http://hw.rosalinux.ru/index.php?probe=6a1ed506bc
Comment 10 Konstantin Vlasov 2015-04-30 17:25:27 MSD
I tried i586 architecture on two VirtualBox machines, on real hardware, in installed mode, in Live mode, Russian and English interface. The issue is not reproducible. Can you get it on any other system? I suspect there is something wrong with KDE settings or services on that particular installation.
Comment 11 Konstantin Vlasov 2015-04-30 18:46:39 MSD
In the meantime, here is the fix for the "Clear" function:
https://abf.rosalinux.ru/build_lists/2495988
https://abf.rosalinux.ru/build_lists/2495989
Comment 12 Vladimir Potapov 2015-05-07 05:02:23 MSD
The update is sent to expanded testing
***************************************
Comment 13 Vladimir Potapov 2015-05-12 18:14:41 MSD
rosa-imagewriter-2.6.0.0-4
https://abf.rosalinux.ru/build_lists/2495988
https://abf.rosalinux.ru/build_lists/2495989
*********************** Advisory ***************************
* Added the "Clear" button for destroying partition table on the USB flash disk and allowing OS to see its full capacity.
* Path to ISO image can be passed via command line.
* Application added to the Dolphin context menu in KDE, and in the list of associations in GNOME.
* Various minor fixes and improvements.
************************************************************
QA Verified