Bug 5407 - [UPDATE REQUEST] RetroArch 1.0.0.3 Released Fixes ARM Compatibility
: [UPDATE REQUEST] RetroArch 1.0.0.3 Released Fixes ARM Compatibility
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-18 02:05 MSD by Zombie Ryushu
Modified: 2015-07-08 22:18 MSD (History)
1 user (show)

See Also:
RPM Package: retroarch
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2015-04-18 02:05:35 MSD
RetroArch 1.0.0.3 Released Fixes ARM Compatibility with Linux on ARM and Android ARM Builds of RetroArch inter-networking. Prior to this ARM Devices could not internetwork games with x86 running Devices. I request that Retroarch be upgraded to resolve this compatibility problem.
Comment 1 Andrey Bondrov 2015-04-20 16:44:43 MSD
There's no 1.0.0.3 final release yet ( https://github.com/libretro/RetroArch/releases ). Last time I checked git snapshot it was too buggy to push to updates. But maybe current snapshot is stable. I'll check it.
Comment 2 Andrey Bondrov 2015-04-20 17:10:08 MSD
Well, latest snapshot seems to be better than last time I tried. But still buggy. For example, "Load content (History)" sometimes makes RetroArch freeze. And toggle fullscreen key creates multiple windows of RetroArch (one window for every key press). I guess we should wait for better snapshot.
Comment 3 Zombie Ryushu 2015-07-08 21:19:45 MSD
This bug is fixed with RetroArch 1.2, but I need a favor. I have tested RetroArch 1.2, on Rosa 2012.1, and it works and I'd like to request an official Backport.
Comment 4 Andrey Bondrov 2015-07-08 22:04:22 MSD
(In reply to comment #3)
> This bug is fixed with RetroArch 1.2, but I need a favor. I have tested
> RetroArch 1.2, on Rosa 2012.1, and it works and I'd like to request an
> official Backport.

Done, I pushed RetroArch 1.2 to rosa2012.1 backports.

I also tried to backport libretro but mednafen_supergrafx_libretro.so build failed (shouldn't be hard to fix, it's just -lrt should be passed to g++ when building this core, but I don't have time for it; so if you create a patch, I'll backport libretro).
Comment 5 Zombie Ryushu 2015-07-08 22:18:37 MSD
The build of Genesis Plus GX used in our version of libretro has a horrifyingly bad bug that causes screechy audio when playing OGG Vorbis CD Tracks. I worked this out with the maintainer Ekkke upstream. Its fixed on my systems. But Rosa itself is still broken. The issue is sometimes the "Tracks" fail to seek right, or the tracks get Parsed as Waves Rather than Oggs.