Bug 5403 - rpm -qf `which xx` not working
: rpm -qf `which xx` not working
Status: RESOLVED NOTABUG
Product: Websites
Classification: ROSA Infrastructure
Component: Bugzilla
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-17 00:35 MSD by Shalok Shalom
Modified: 2015-04-17 12:30 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shalok Shalom 2015-04-17 00:35:43 MSD
http://funkyimg.com/i/VYXA.png
Comment 1 Denis Silakov 2015-04-17 00:41:46 MSD
Well, you should use backticks ("`") around the "which" command:

$ rpm -qf `which plasma-applet-icontask`

See, for example, some Bash guide:
http://tldp.org/LDP/Bash-Beginners-Guide/html/sect_03_04.html
(section 3.4.5 - Command substitution)

or questions like this:
http://unix.stackexchange.com/questions/27428/what-does-backquote-backtick-mean-in-bash
Comment 2 Shalok Shalom 2015-04-17 12:23:33 MSD
Take a short look on my pic, i try it like that as well.
Also with ".
Comment 3 Denis Silakov 2015-04-17 12:27:18 MSD
I took a look and you didn't tried that:)

Yo have tried " and ' , while you should use `. This symbol is usually located in the upper left corner of the keyboard, just under the "Esc" key.

Maybe you have some tricky font that doesn't allow to distinguish single quote (') from backtick (`) ?
Comment 4 Shalok Shalom 2015-04-17 12:30:19 MSD
Thanks, you are correct. Tricky command :P ;)