Bug 5394 - Enable support for WiMAX in the NetworkManager
: Enable support for WiMAX in the NetworkManager
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-14 15:59 MSD by Andrey Ponomarenko
Modified: 2015-04-23 15:54 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2015-04-14 15:59:31 MSD
Description of problem:

WiMax cards are currently not supported by the NetworkManager.

The sample card is "Intel Centrino Wireless-N + WiMAX 6150".

HW probe of the card on Dell notebook: http://hw.rosalinux.ru/index.php?probe=fb39b68c06

HW probe of the card on Sony notebook: http://hw.rosalinux.ru/index.php?probe=c3a3a1b313

Support for WiMAX can be enabled by the --enable-wimax configure option. The issue is that WiMAX has a restricted license. So a separate package (say, networkmanager-wimax) should be created in the restricted repository.


Version-Release number of selected component (if applicable): R5


How reproducible: always


Steps to Reproduce:
1. Try to run this command: nmcli device wimax list
2.
3.
Comment 1 Denis Silakov 2015-04-23 15:54:50 MSD
Wimax support was dropped in NetworkManager several days ago:

http://anzwix.com/a/NetworkManager/WimaxDropWiMAXSupportbgo747846