Bug 5354 - [UPDATE REQUEST] gdk-pixbuf2.0
: [UPDATE REQUEST] gdk-pixbuf2.0
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-07 19:21 MSD by Arkady L. Shane
Modified: 2015-04-13 13:38 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arkady L. Shane 2015-04-07 19:21:52 MSD
Advisory:

Fix 32bit modules generation on 64bit systems. For example, before epsxe1.9 (package) segfault on 64 systems.

How to test:

1. install on 64bit system package epsxe1.9
2. run epsxe1.9-start - should be SEGFAULT

3. Update gdk-pixbuf2.0 from BOTH 32 and 64bit containers
4. run epsxe1.9-start - should be ok.

Buildlists:

https://abf.rosalinux.ru/build_lists/2488554
https://abf.rosalinux.ru/build_lists/2488553
Comment 1 Andrey Bondrov 2015-04-07 20:34:33 MSD
(In reply to comment #0)
> Advisory:
> 
> Fix 32bit modules generation on 64bit systems. For example, before epsxe1.9
> (package) segfault on 64 systems.
> 
> How to test:
> 
> 1. install on 64bit system package epsxe1.9
> 2. run epsxe1.9-start - should be SEGFAULT
> 
> 3. Update gdk-pixbuf2.0 from BOTH 32 and 64bit containers
> 4. run epsxe1.9-start - should be ok.
> 
> Buildlists:
> 
> https://abf.rosalinux.ru/build_lists/2488554
> https://abf.rosalinux.ru/build_lists/2488553

Looks like you forgot to add Conflicts after you re-organized subpackages:

https://abf.rosalinux.ru/import/gdk-pixbuf2.0/diff/ab4af97c4beb677237d9a9baa77ac70f84e53179...6e490364ccc25101cea608efb529d6168374fd41#diff-0
Comment 3 Vladimir Potapov 2015-04-09 12:34:49 MSD
test run on i586:
*************
epsxe-start
 * Running ePSXe emulator version 1.6.0. 

Gtk-WARNING **: Failed to load module "libcanberra-gtk-module.so": libcanberra-gtk-module.so: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога
**********************


Is it correct?
Comment 4 Arkady L. Shane 2015-04-09 13:03:18 MSD
It looks like missing libcanberra-gtk0 32bit package. Exactly not a problem of gdk-pixbuf. This depend must be in epsxe1.9 package.
Comment 5 Vladimir Potapov 2015-04-09 13:32:50 MSD
The update is sent to expanded testing
**************************************
Comment 6 Andrey Bondrov 2015-04-09 13:59:41 MSD
(In reply to comment #3)
> Gtk-WARNING **: Failed to load module "libcanberra-gtk-module.so":
> libcanberra-gtk-module.so: невозможно открыть разделяемый объектный файл:
> Нет такого файла или каталога
> **********************
> 
> Is it correct?

Just ignore it.
Comment 7 Vladimir Potapov 2015-04-13 13:27:10 MSD
gdk-pixbuf2.0-2.30.8-10
https://abf.rosalinux.ru/build_lists/2488608
https://abf.rosalinux.ru/build_lists/2488609
***************************** Advisory ****************************
Fix 32bit modules generation on 64bit systems. For example, before epsxe1.9 (package) segfault on 64 systems.

*******************************************************************
QA Verified