Bug 533 - Stack folder in openning state prevents starting ksnapshot
: Stack folder in openning state prevents starting ksnapshot
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 21:23 MSD by FirstLevel
Modified: 2012-10-02 12:10 MSD (History)
4 users (show)

See Also:
RPM Package: ksnapshot-4.8.2-1.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-07-17 21:23:42 MSD
Description of problem:
If I press PrintScreen button the Ksnapshot is starting.
But if I click on stackfolder applet and this applet is in openning state the PrintScreen button does not start Ksnapshot.
Another words stack folder in openning state prevents starting ksnapshot

kosta ~ $ rpm -qa | grep stack
plasma-applet-stackfolder-0.2.1-23-rosa.lts2012.0.i586
kosta ~ $ rpm -qa | grep ksnapshot
ksnapshot-4.8.2-1-rosa.lts2012.0.i586

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Ural Mullabaev 2012-07-19 09:08:07 MSD
We'll take up this issue.
Comment 2 Denis Koryavov 2012-07-24 17:06:37 MSD
I think this is not a bug, because you also can't run Ksnapshot even if you just open some menu by the right click. I think it is a feature, or bug of Ksnapshot. Anyway it is not a bug of StackFolder.
Comment 3 FirstLevel 2012-07-24 17:20:07 MSD
(In reply to comment #2)
> I think this is not a bug, because you also can't run Ksnapshot even if you
> just open some menu by the right click. I think it is a feature, or bug of
> Ksnapshot. Anyway it is not a bug of StackFolder.

Should I replace plasma-applet-stackfolder-0.2.1-23.src.rpm on ksnapshot-*.rpm in RPM package field?
Comment 4 Denis Koryavov 2012-07-24 17:28:37 MSD
I think yes.
Comment 5 Pavel Shved 2012-07-24 17:34:31 MSD
I think this isn't a bug in ksnapshot.  I observed that KDE shortcuts set via "Shortcuts and Gestures" do not work when you open some menus as well.  And invocation of ksnapshot at PrintScreen is just a part of these shortcuts.  So this is most likely a broader KDE bug.

As a workaround, I suggest setting a timer in ksnapshot, and opening StackFolder while it ticks.
Comment 6 Ural Mullabaev 2012-07-25 10:34:19 MSD
Yes, it isn't bug of ksnapshot. It depend of type of popup window that causes many problems. We are trying to change it now.
Comment 7 Denis Koryavov 2012-10-02 12:10:10 MSD
Resolved as update for bug #800.