Bug 5294 - Update default shorewall configs to allow samba shares and to be compatible with drakfirewall
: Update default shorewall configs to allow samba shares and to be compatible w...
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-27 23:04 MSK by Denis Silakov
Modified: 2015-04-07 18:00 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments
ss (5.80 KB, application/x-7z-compressed)
2015-04-07 16:20 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2015-03-27 23:04:45 MSK
When working on bug #5244, we decided that we should improve default shorewall configs to allow samba shares and to be compatible with drakfirewall.
Comment 1 Denis Silakov 2015-03-27 23:05:55 MSK
Advisory:
Updated default shorewall configs to allow samba shares and to be compatible with drakfirewall.

Note that these changes will only take effect if you don't have shorewall installed and don't have /etc/shorewall folder.

Build lists:
(32bit) https://abf.io/build_lists/2476041
(64bit) https://abf.io/build_lists/2476042
Comment 2 Vladimir Potapov 2015-04-02 19:51:52 MSD
If I delete /etc/shorewall and reinstall - all ok
If U update system with work samba - fail (drakfirewall show firewall off, samba don't work)
******************************************************
QA Denied
Comment 3 Denis Silakov 2015-04-03 00:55:11 MSD
Indeed, the update process could lead to corruption of config files.


New build lists:

https://abf.rosalinux.ru/build_lists/2487339
https://abf.rosalinux.ru/build_lists/2487340
Comment 4 Vladimir Potapov 2015-04-07 10:10:12 MSD
1) Set up fresh i586 iso
2) Install shorewall update (and all update)
3) Samba work correct (before and after update - ok)
4) Set samba select in firewall (by gui)
5) Reboot
6) Samba ok
7) Disable firefall by gui
8) reboot
9) Samba fail :-(
10) enable firewall by GUI
11) samba fail :-(

Disable firewall break samba
**************************
QA Denied
Comment 5 Denis Silakov 2015-04-07 12:17:29 MSD
Are you sure that the failure is caused by updates from this bug? Does samba work fine in your scenario without shorewall updates? If yes, then could you provide contents of /etc/shorewall/ folder in that case?
Comment 6 Vladimir Potapov 2015-04-07 16:20:49 MSD
Created attachment 3874 [details]
ss

without updates all work with all cases
Comment 7 Vladimir Potapov 2015-04-07 17:24:12 MSD
(In reply to comment #6)
> Created attachment 3874 [details]
> ss
> 
> without updates all work with all cases
for x64 (new iso) too... all work in all cases without updates
Comment 8 Denis Silakov 2015-04-07 18:00:11 MSD
Ok, more investigation are required in this area.

Let's postpone this update for now. Patches in git have been reverted for now.