Bug 5290 - urpmq doubles
: urpmq doubles
Status: RESOLVED NOTABUG
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Denis Silakov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-27 18:56 MSK by Vladimir Potapov
Modified: 2015-03-27 19:02 MSK (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2015-03-27 18:56:49 MSK
urpmq --whatrequires dolphin
audiokonverter
audiokonverter
audiokonverter
audiokonverter
audiokonverter
audiokonverter
audiokonverter
audiokonverter
dolphin
konqueror
konqueror
konqueror
konqueror
konqueror
konqueror
konqueror
konqueror
task-kde4-minimal
task-kde4-minimal
task-kde4-minimal
task-kde4-minimal
task-kde4-minimal
task-kde4-minimal
task-kde4-minimal
task-kde4-minimal
Comment 1 Denis Silakov 2015-03-27 19:02:29 MSK
It's not a bug, it is urpmq 'feature'.

Just launch "urpmq --whatrequires dolphin --sources" and you will see that these are really different packages ("different" mean that they either have different name-version-release values or come from different repositories).

This is how urpmq worked from the very beginning and I don't see any need to change this behavior. If you like command line, then follow the Unix way and additionally process urpmq output by another command, e.g. "urpmq --whatrequires dolphin | sort -u".