Bug 5259 - international dead keys no more working
: international dead keys no more working
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: Eugene Shatokhin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-23 08:11 MSK by andrea_scopelliti
Modified: 2015-03-26 00:21 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andrea_scopelliti 2015-03-23 08:11:49 MSK
Description of problem:
When I installed Rosa Fresh R5, I choose a USA INTl keyboard and the dead keys did work. Today, having problems with the " character I decided to modify my keyboard layout in KCC. 
Went to Input Devices - Keyboard, hardware tab and choose a Generic 105-key (Intl)PC. Then I moved to the Layouts Tab and configured an English(US) layout and as Variant English (International altgr with dead keys.
Since then there was no way to have the dead keys work. I even tried to manually configure /etc/sysconfig/keyboard and /etc/X11/xorg.conf.d/00-keyboard.conf with no effect.
As a counter-check I tried to configure the same keyboard on another desktop running Rosa Fresh R5 with the same result.

Version-Release number of selected component (if applicable):


How reproducible:
Install a Keyboard with dead keys variant

Steps to Reproduce:
1.
2.
3.
Comment 1 andrea_scopelliti 2015-03-23 16:39:34 MSK
Trying to deepen the bug, I made the same test on my laptop that I didn't update since the very first of January (I had to use it with Win in this period). The dead keys were working. Then I left it on to update and then switched it off.
When I switched it on again the dead keys were no more working.
As it seems that the only file that KDE changes when modifying the keyboard configuration is kxkbrc I report its listing:

[Layout]
DisplayNames=
LayoutList=us(altgr-intl)
LayoutLoopCount=-1
Model=pc105
ResetOldOptions=false
ShowFlag=false
ShowLabel=true
ShowLayoutIndicator=true
ShowSingle=false
SwitchMode=Global
Use=true
Comment 2 Denis Silakov 2015-03-24 10:44:00 MSK
Let's try to investigate, though I am not sure where the source of the problem lies.
Comment 3 andrea_scopelliti 2015-03-25 03:46:55 MSK
THe reason why I installed yum was to try to use the installation helper file from Kicad: all the red hat derivative distributions are supposed to use yum. As you may know kikad is no more releasing stable releases of its program that is actually based on a launchpad distribution.
I have been able to install Kicad manually but it has been a nightmare, as most of the required dependencies are not installed by default on rosa and some of the needed headers cited in the documentation are not included in the corresponding rosa rpm's.
Yum could ease this installation.
Comment 4 Denis Silakov 2015-03-26 00:21:11 MSK
I see. But I doubt that you will be able to use Yum in ROSA or other Mandriva derivatives, since we all use urpmi with is own structure of repositories. Could you please point me to that kicad helper file? I'll take a look.

We can also try to update kicad in our repositories and do it periodically (like e.g. Fedora guys do). Currently we have a very outdated version, it looks like our maintainers stopped to update the package after kicad stopped releasing stable versions.

Btw, I think this bug is not the best place to discuss this topic, I would suggest to open a new one. Otherwise we will forget about the initial issues reported here.