Bug 5253 - Adjust Requires for kdebase4-runtime
: Adjust Requires for kdebase4-runtime
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 5208
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-22 07:29 MSK by Andrey Bondrov
Modified: 2015-03-30 09:44 MSD (History)
1 user (show)

See Also:
RPM Package: kdebase4-runtime
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2015-03-22 07:29:36 MSK
kdebase4-runtime can be used inside Plamsa 5 desktop, so it shouldn't require packages that cannot be co-installed with Plasma 5. libkactivities and polkit-kde-agent-1 are now required by kdebase4-workspace instead of kdebase4-runtime.
Comment 1 Andrey Bondrov 2015-03-22 07:32:17 MSK
Advisory: "No no longer require libkactivities and polkit-kde-agent-1, they are now required by kdebase4-workspace"

https://abf.rosalinux.ru/build_lists/2474795
https://abf.rosalinux.ru/build_lists/2474796

P.S. Please approve this update along with #5208, it's just a rebuild without 2 mentioned Requires, no need for extended testing here.
Comment 2 Andrey Bondrov 2015-03-24 09:37:26 MSK
I need to do more work on this package.
Comment 3 Andrey Bondrov 2015-03-24 12:37:12 MSK
1. kdebase4-runtime

Advisory: "Тo longer require libkactivities and polkit-kde-agent-1, they are now required by kdebase4-workspace. Split khelpcenter to individual package."

https://abf.rosalinux.ru/build_lists/2475377
https://abf.rosalinux.ru/build_lists/2475378

2. kdebase4-workspace

Advisory: "Require khelpcenter, it was split from kdebase4-runtime package"

https://abf.rosalinux.ru/build_lists/2475407
https://abf.rosalinux.ru/build_lists/2475408
Comment 4 Andrey Bondrov 2015-03-24 21:19:54 MSK
New build lists for kdebase4-workspace.

1. kdebase4-runtime

Advisory: "Тo longer require libkactivities and polkit-kde-agent-1, they are now required by kdebase4-workspace. Split khelpcenter to individual package."

https://abf.rosalinux.ru/build_lists/2475377
https://abf.rosalinux.ru/build_lists/2475378

2. kdebase4-workspace

Advisory: "New version 4.11.17 with minor translation updates. Add patch to fix Aurorae decoration engine (KDE bug #345447). Make kdebase4-workspace require khelpcenter, it was split from kdebase4-runtime package"

https://abf.rosalinux.ru/build_lists/2475595
https://abf.rosalinux.ru/build_lists/2475596
Comment 5 Vladimir Potapov 2015-03-26 21:05:44 MSK
The update is sent to expanded testing
**************************************
Comment 6 Vladimir Potapov 2015-03-30 09:15:39 MSD
kdebase4-runtime-4.14.3-5
https://abf.rosalinux.ru/build_lists/2475377
https://abf.rosalinux.ru/build_lists/2475378

kdebase4-workspace-4.11.17-1
https://abf.rosalinux.ru/build_lists/2475595
https://abf.rosalinux.ru/build_lists/2475596

*************************** Advisory ****************************
kdebase4-runtime: "Тo longer require libkactivities and polkit-kde-agent-1, they are now required by kdebase4-workspace. Split khelpcenter to individual package."

kdebase4-workspace: "New version 4.11.17 with minor translation updates. Add patch to fix Aurorae decoration engine (KDE bug #345447). Make kdebase4-workspace require khelpcenter, it was split from kdebase4-runtime package"
*****************************************************************
QA Verified