Bug 5247 - crashes with error: /usr/lib64/libcurl.so.4: undefined symbol: SSL_CTX_set_srp_password
: crashes with error: /usr/lib64/libcurl.so.4: undefined symbol: SSL_CTX_set_sr...
Status: RESOLVED NOTABUG
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-20 20:22 MSK by andrea_scopelliti
Modified: 2015-03-24 10:46 MSK (History)
1 user (show)

See Also:
RPM Package: yum-3.2.29-2-rosa2014.1.noarch.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andrea_scopelliti 2015-03-20 20:22:00 MSK
Description of problem:
yum when launched from konsole crashes with error: 
/usr/lib64/libcurl.so.4: undefined symbol: SSL_CTX_set_srp_password.

The full error message is:
[root@DESKTOP-1 Downloads]# yum
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   /usr/lib64/libcurl.so.4: undefined symbol: SSL_CTX_set_srp_password

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.7.9 (default, Jan 12 2015, 09:01:52) 
[GCC 4.9.2 20140811 (ROSA)]

If you cannot solve this problem yourself, please go to 
the yum faq at:
  http://yum.baseurl.org/wiki/Faq



Version-Release number of selected component (if applicable):
3.2.29-2

How reproducible:
install and launch yum

Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Silakov 2015-03-21 23:23:38 MSK
This is likely caused by the same reason as bug #5246
Comment 2 Denis Silakov 2015-03-24 10:46:02 MSK
See bug #5246 for discussion. This one is definitely caused by the same reason.

Though note that yum in ROSA is not intended to work. It is still present in contrib repository since somebody wanted to make it work some time ago. But it is possible that we will drop it in future if there are no more enthusiasts to play with it.