Bug 5239 - Teach urpmi to understand ROSA Enterprise Desktop mirror structure
: Teach urpmi to understand ROSA Enterprise Desktop mirror structure
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest blocker
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-20 15:24 MSK by Denis Silakov
Modified: 2015-03-23 11:23 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2015-03-20 15:24:52 MSK
In bug #5232 we discovered that currently urmpi is not able to connect to ROSA Enterprise Desktop mirrors. Let's fix this and update urmpi in to recognize both Fresh and Enterprise mirrors.
Comment 1 Denis Silakov 2015-03-20 15:26:09 MSK
Advisory:
Updated urpmi to be able to connect to both ROSA enterprise Desktop and ROSA Desktop Fresh mirrors.

Build lists:
https://abf.io/build_lists/2474281
https://abf.io/build_lists/2474282

Note for testers:
this update should not affect Desktop Fresh in any way, and should fix bug #5232 for RED.
Comment 2 Vladimir Potapov 2015-03-20 19:07:02 MSK
В x64 не хватает restricted32 testing и non-free32 testing
Comment 3 Denis Silakov 2015-03-21 19:06:33 MSK
Тестинга в RED нет и не перполагается by design - см. bug #5232.

А этот update request - для фреша.
Comment 4 Vladimir Potapov 2015-03-22 19:25:40 MSK
(In reply to comment #3)
> Тестинга в RED нет и не перполагается by design - см. bug #5232.
> 
> А этот update request - для фреша.
Так я и обращаю внимание, что для фреша при обновлении не добавляются 32-разрядные тестинги restricted и non-free. Если уж взялись править, то нужно до конца поправить.
Comment 5 Denis Silakov 2015-03-23 00:56:34 MSK
То, что добавляется при клике на кнопку "Add repositories", определяется структурой файлов на сервере и к urpmi отношения не имеет. Соответственно, к этому update request'у это тоже отношения не имеет.

А этот баг - про то, что urpmi в RED подключает репы rosa2014.1. Т.е. должны подключаться mirror.rosalab.ru/rosa/red/..., а подключаются mirror.rosalab.ru/rosa/rosa2014.1/...
Comment 6 Denis Silakov 2015-03-23 01:15:49 MSK
... а файлики на серверах я подправил, завтра должны начать расползаться по зеркалам, и тогда будет появляться restricted32_testing и non-free32-testing в 64битных системах.
Comment 7 Vladimir Potapov 2015-03-23 07:42:20 MSK
...извлечение не удалось: сбой aria2: завершён с 3
для источника «restricted testing (distrib17)» не найдены метаданные
...извлечение не удалось: сбой aria2: завершён с 3
для источника «Restricted32 Testing (distrib20)» не найдены метаданные
Comment 8 Vladimir Potapov 2015-03-23 07:43:50 MSK
urpmi-7.32.3-41
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2474281/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2474282/x86_64/main/release/
***************************** Advisory ***************************
Updated urpmi to be able to connect to both ROSA enterprise Desktop and ROSA Desktop Fresh mirrors.
******************************************************************
QA Verified
Comment 9 Denis Silakov 2015-03-23 10:31:29 MSK
(In reply to comment #7)
> ...извлечение не удалось: сбой aria2: завершён с 3
> для источника «restricted testing (distrib17)» не найдены метаданные
> ...извлечение не удалось: сбой aria2: завершён с 3
> для источника «Restricted32 Testing (distrib20)» не найдены метаданные

мм, сейчас гляну.
Comment 10 Denis Silakov 2015-03-23 10:43:12 MSK
Должно починиться.