Bug 5218 - [UPDATE REQUEST] livecd-tools-21.1-17
: [UPDATE REQUEST] livecd-tools-21.1-17
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-19 16:14 MSK by Konstantin Vlasov
Modified: 2015-03-30 11:22 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2015-03-19 16:14:59 MSK
Bugfix in livecd-tools.
Comment 1 Konstantin Vlasov 2015-03-19 16:15:49 MSK
https://abf.rosalinux.ru/build_lists/2474140
https://abf.rosalinux.ru/build_lists/2474141

Advisory: OS name for boot menu entries was taken from wrong system-release file.
Comment 2 Konstantin Vlasov 2015-03-19 20:05:55 MSK
No, discard this request, it's not working properly.
Comment 3 Konstantin Vlasov 2015-03-20 16:54:58 MSK
Ah, it seems the update is working fine, it was a problem with another package. Restoring the QA request.

Sample image built with this update:
https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/product_build_lists/9973
Comment 4 FirstLevel 2015-03-25 14:45:49 MSK
(In reply to comment #3)
> Ah, it seems the update is working fine, it was a problem with another
> package. Restoring the QA request.
> 
> Sample image built with this update:
> https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/
> product_build_lists/9973

What does it mean? "Advisory: OS name for boot menu entries was taken from wrong system-release file."
How do we see it?
Comment 5 Konstantin Vlasov 2015-03-25 15:00:04 MSK
When ISO image is created using livecd-tools, it takes OS name for boot menu entries from the file /etc/system-release. But instead of using /etc/system-release of the target OS (that is, the one from the newly built ISO), it took /etc/system-release from the main OS, where livecd-tools itself was running. One of the result of this was RED image booting with entries named "ROSA Enterprise Desktop X2 for x86_64" even for 32-bit images - just because the build chroot is always 64-bit.

I'm not sure how you can check the fix now - RED name was changed so that now it's always "ROSA Enterprise Desktop X2" without architecture, and it became identical with and without fix. Maybe, it makes sense only to check for regressions now.
Comment 6 Alexander Petryakov 2015-03-26 21:29:51 MSK
Both system (32/64 bit) successfully installed in virtualbox.
iso image from https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/product_build_lists/9973
Comment 7 Vladimir Potapov 2015-03-26 21:30:54 MSK
The update is sent to expanded testing
**************************************
Comment 8 Vladimir Potapov 2015-03-30 09:17:12 MSD
livecd-tools-21.1-17
https://abf.rosalinux.ru/build_lists/2474140
https://abf.rosalinux.ru/build_lists/2474141
******************************* Advisory ********************************
OS name for boot menu entries was taken from wrong system-release file.
*************************************************************************
QA Verified