Bug 5216 - dkms-virtualbox
: dkms-virtualbox
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Low normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-19 15:25 MSK by Shalok Shalom
Modified: 2016-02-20 17:10 MSK (History)
2 users (show)

See Also:
RPM Package: virtualbox
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shalok Shalom 2015-03-19 15:25:55 MSK
I install Virtualbox, create a disk, switch to the rt kernel, reboot and the virtualbox dont work:

"The virtual machine 'GNOME 3' has terminated unexpectedly during startup with exit code 1 (0x1).

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Komponente:Machine
Interface:IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}"

Then:

"Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary."

When i reinstall virtualbox dont solve this the issue, /etc/init.d/vboxdrv setup is not installed.


Steps to Reproduce:
1. Install virtualbox with dkms
2. Switch to kernel-nrj-realtime-latest and restart
3. Create a disk (ROSA 64, in my case)
4. Launch virtualbox and then the virtual OS.

(I preconfigure the settings, like 3D acceleration and the live iso for the virtual IDE drive, before i install the rt kernel)
Comment 1 Eugene Shatokhin 2015-03-19 16:37:07 MSK
nrj-realtime kernel is actually a strange beast, far from realtime at all. It is not recommended to use it.

For these reasons, this kernel flavour was moved to Contrib some months ago and support for it is low priority.

Officially supported flavours, which are now in Main repo:
* nrj-desktop 
* nrj-laptop 
* nrj-desktop-pae (i586)
* nrj-laptop-pae (i586)

If the problem persists with these kernels, please let us know here.
Comment 2 Eugene Shatokhin 2015-03-19 16:38:55 MSK
And by the way, please check that the appropriate kernel-nrj-realtime-devel package is installed.

If it is, then DKMS build log for VBox drivers is also needed to see what is going on.
Comment 3 Denis Silakov 2016-01-26 12:36:05 MSK
Is this issue is still valid with modern kernels?

Note that in the original report you looked for /etc/init.d/vboxdrv; this is wrong, we use /etc/init.d/virtualbox service. It is a part of virtualbox package.

So if you still experience any issues, please launch
# /etc/init.d/virtualbox start

The root of the problem is that either dkms failed to build driver for nrj-runtime kernel or you have another virtualization system (e.g., qemu/kvm) loaded that prevented vboxdrv from load.
Comment 4 Denis Silakov 2016-02-20 17:10:30 MSK
Marking as "worksforme" for now since we don't have a reproducer.