Bug 5213 - Default KTorrent search engine and others are broken
: Default KTorrent search engine and others are broken
Status: RESOLVED LATER
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-18 23:18 MSK by Shalok Shalom
Modified: 2016-12-09 09:45 MSK (History)
2 users (show)

See Also:
RPM Package: ktorrent
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shalok Shalom 2015-03-18 23:18:05 MSK
The default search engine of KTorrent, called Bitenova, KTorrent and BTJunkie are broken/down, the BitTorrent engine shows unrelated stuff, namely no torrents, just casual web results.


Steps to Reproduce:

1. Enable the search module
2. Search :)
Comment 1 Denis Silakov 2015-05-21 10:21:44 MSD
Advisory:
Adjusted search engines in ktorrent - drop non-working ones, added some new ones.

Build lists:
https://abf.rosalinux.ru/build_lists/2503067
https://abf.rosalinux.ru/build_lists/2503068
Comment 2 Vladimir Potapov 2015-05-21 13:29:01 MSD
After the update, if I enable search and enter search words, ktorrent crash
Comment 3 Denis Silakov 2015-05-21 14:01:49 MSD
Could you provide more details - have you updated both ktorrent and libktorrent, do you use 32 or 64bit system, which words did you enter and which search engine was enabled?

In addition, it would be nice to launch ktorrent from console and paste its output here.

Up to now, I couldn't reproduce the crash.
Comment 4 Vladimir Potapov 2015-05-21 14:37:52 MSD
1) x64
2) before update, I enable search module and set pirate buy to default
3) run from krunner
4) any word to crash
Comment 5 Vladimir Potapov 2015-05-21 18:14:37 MSD
crash after update
*********************
QA Denied
Comment 6 Shalok Shalom 2015-08-17 15:50:24 MSD
There are still/again a lot of broken search engines.
Please retry the update ?
Comment 7 Denis Silakov 2016-12-09 09:45:55 MSK
This is done in the scope of a new platform, rosa2016.1. Nobody suggested a way of correctly fixing this in rosa2014.1 without breaking on old user configs.