Bug 5210 - Quassel offer #mandriva (#moondrake) by default
: Quassel offer #mandriva (#moondrake) by default
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-18 18:39 MSK by Shalok Shalom
Modified: 2015-03-30 11:12 MSD (History)
3 users (show)

See Also:
RPM Package: quassel
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
old32.jpg (87.64 KB, image/jpeg)
2015-03-19 15:28 MSK, FirstLevel
Details
new32.jpg (94.18 KB, image/jpeg)
2015-03-19 15:29 MSK, FirstLevel
Details
nothing changes.jpg (112.10 KB, image/jpeg)
2015-03-20 10:34 MSK, FirstLevel
Details
old-01.jpg (95.14 KB, image/jpeg)
2015-03-23 10:55 MSK, FirstLevel
Details
Temp2.zip - screenshots (407.45 KB, application/octet-stream)
2015-03-23 10:56 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shalok Shalom 2015-03-18 18:39:16 MSK
Quassel offer #mandriva (#moondrake) by default, i guess this count for other IRC clients as well, its already fixed in Konversation:

http://bugs.rosalinux.ru/show_bug.cgi?id=926

Version-Release number of selected component (if applicable):

0.8.2

Steps to Reproduce:
1. Launch Quassel for the first time
2. Look :)
Comment 1 Denis Silakov 2015-03-19 12:40:47 MSK
Advisory:

Updated quassel to version 0.11.0, changed default channel or #rosa-devel at irc.rosalab.ru

Build lists:
https://abf.io/build_lists/2474083
https://abf.io/build_lists/2474084

Note:
I am not sure that @rosa-devel is the best choice, but we don't have official irc channel for ROSA (it looks like most users prefer forums now), but #rosa-devel is definitely better than old #mandriva.
Comment 2 Shalok Shalom 2015-03-19 15:17:36 MSK
That is great, i search since months for a rosa irc channel and thought, there is none. 
So i think, most users just dont know, that rosa-devel exist, especially on that server. Thanks a lot, i suggest to do the same with Konversation, Kvirc, HexChat, XChat and WeeChat. (I guess irssi and rhapsody dont offer such a functionality?)
Comment 3 Denis Silakov 2015-03-19 15:20:14 MSK
Maybe this makes sense, but initially #rosa-devel was intended for developers only. Now most developers prefer other means of communication and this channel is a little abandoned...
Comment 4 FirstLevel 2015-03-19 15:28:34 MSK
32bit

install old quassel, plug container, update, launch - ok
plug container, install new quassel, launch - ok

64bit

install old quassel, plug container, update, launch - ok
plug container, install new quassel, launch - ok
Comment 5 FirstLevel 2015-03-19 15:28:56 MSK
Created attachment 3808 [details]
old32.jpg
Comment 6 FirstLevel 2015-03-19 15:29:11 MSK
Created attachment 3809 [details]
new32.jpg
Comment 7 FirstLevel 2015-03-19 15:30:39 MSK
I could not pass this update because we have localization degradation.
Old version old32.jpg
New version new32.jpg
Comment 8 FirstLevel 2015-03-19 15:32:14 MSK
It "Updated quassel to version 0.11.0, changed default channel or #rosa-devel at irc.rosalab.ru" - ok
Comment 9 FirstLevel 2015-03-19 15:33:15 MSK
************************ Advisory **********************
I could not pass this update because we have localization degradation.
********************************************************
QA Verified
Comment 10 Denis Silakov 2015-03-19 18:09:41 MSK
Indeed, due to incorrect build settings, translations were lost.

Advisory:

Updated quassel to version 0.11.0, changed default channel or #rosa-devel at irc.rosalab.ru

Please try these new build lists:
https://abf.io/build_lists/2474164
https://abf.io/build_lists/2474165

Some regressions can still occur (since I can see untranslated strings), but likely they are not crucial.
Comment 11 FirstLevel 2015-03-20 10:34:46 MSK
Created attachment 3824 [details]
nothing changes.jpg
Comment 12 FirstLevel 2015-03-20 10:35:03 MSK
(In reply to comment #10)
> Indeed, due to incorrect build settings, translations were lost.
> 
> Advisory:
> 
> Updated quassel to version 0.11.0, changed default channel or #rosa-devel at
> irc.rosalab.ru
> 
> Please try these new build lists:
> https://abf.io/build_lists/2474164
> https://abf.io/build_lists/2474165
> 
> Some regressions can still occur (since I can see untranslated strings), but
> likely they are not crucial.

Nothing changes - see nothing changes.jpg
Comment 13 Denis Silakov 2015-03-20 12:46:22 MSK
Brr, sorry, I have prepared wrong builds.

These ones should be correct:
https://abf.io/build_lists/2474277
https://abf.io/build_lists/2474278
Comment 14 FirstLevel 2015-03-23 10:44:21 MSK
(In reply to comment #13)
> Brr, sorry, I have prepared wrong builds.
> 
> These ones should be correct:
> https://abf.io/build_lists/2474277
> https://abf.io/build_lists/2474278

32bit

install, plug container, update - ok
plug container, install - ok

64bit

install, plug container, update - ok
plug container, install - ok
Comment 15 FirstLevel 2015-03-23 10:55:21 MSK
Localization degradation
new-01.jpg
new-02.jpg
new-03.jpg

old-01.jpg
old-02.jpg
old-03.jpg
Comment 16 FirstLevel 2015-03-23 10:55:39 MSK
Created attachment 3831 [details]
old-01.jpg
Comment 17 FirstLevel 2015-03-23 10:56:45 MSK
Created attachment 3832 [details]
Temp2.zip - screenshots
Comment 18 Denis Silakov 2015-03-23 11:38:00 MSK
I'm afraid this will require some time to fix - po contains some other untranslated strings, but it looks to be slightly outdated (or maybe some strings are not picked up for some other reason). I suggest to push this update (since it was requested by a non-Russian speaking person) and create a separate bug for Russian localization in quassel. Finally, the regress is not crucial.
Comment 19 Vladimir Potapov 2015-03-25 11:42:27 MSK
The update is sent to expanded testing
**************************************
Comment 20 Vladimir Potapov 2015-03-30 08:49:49 MSD
quassel-0.11.0-5
https://abf.io/build_lists/2474277
https://abf.io/build_lists/2474278
********************** Advisory ****************************
Updated quassel to version 0.11.0, changed default channel or #rosa-devel at irc.rosalab.ru
************************************************************
QA Verified