Bug 5190 - [Update Request] DHCP server 4.3.1 enhances LDAP support.
: [Update Request] DHCP server 4.3.1 enhances LDAP support.
Status: RESOLVED DUPLICATE of bug 5098
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Alexey Ivanov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-17 17:27 MSK by Zombie Ryushu
Modified: 2015-04-14 12:03 MSD (History)
1 user (show)

See Also:
RPM Package: dhcp-server
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2015-03-17 17:27:38 MSK
DHCP server 4.3.1 enhances LDAP support. It contains a new LDAP Schema (dhcp.schema) that not only allows for distinct LDAP configuration of redundant DHCP servers, with regard to range, scope, and reservation information, but Lease information from clients instead of in dhcp.leases. This permits multiple DHCP servers to "agree" with each other and not give conflicting info.

Also it allows GSSAPI based Authentication to Bind.

As with Kerberos, a way should be done for the Package manager to update dhcp.schema to reflect this.
Comment 1 Alexey Ivanov 2015-03-18 09:54:29 MSK
Good point. I'll place it on my schedule.
Comment 2 Zombie Ryushu 2015-03-18 14:00:14 MSK
I'm enquiring with the Samba team to see what needs to be done to integrate this with Samba 4, if there are any special steps or modules for this. Don't let this slow you down however.
Comment 3 Alexey Ivanov 2015-03-18 15:21:39 MSK
This task is not especially difficult, and it's better be solved before 5098.
So I've forced it over other tasks. Here is the result:

Build lists:
https://abf.io/build_lists/2473926
https://abf.io/build_lists/2473927

Advisory:

Upgrade dhcp to version 4.3.2.
Fix problem with starting dhcpd and dhcrelay after installation.
Fix warnings thrown by dhcpd due to error in default configuration.
Ship schema files out-of-the-source directly to fresh installations of OpenLDAP for inclusion.
Comment 4 Alexey Ivanov 2015-03-19 15:20:14 MSK
A little improvement may be required. Let's hold it for a moment.
Comment 5 Zombie Ryushu 2015-03-19 15:28:36 MSK
I understand. I'll continue testing.
Comment 6 Alexey Ivanov 2015-04-14 12:03:29 MSD
This is being addressed in Bug 5098 now.

*** This bug has been marked as a duplicate of bug 5098 ***