Bug 5176 - black screen on reboot with kernel without -devel
: black screen on reboot with kernel without -devel
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: unspecified
: All Linux
: Low normal
: ---
Assigned To: Eugene Shatokhin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-14 19:10 MSK by Vladimir Potapov
Modified: 2015-05-15 12:40 MSD (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2015-03-14 19:10:13 MSK
1) Set up kernel-desktop (not nrj), -devel package don't set
2) load with new kernel
plymouth fail (timeout ?)
daemon wait plymouth on black screen many-many times...
Comment 1 Vladimir Potapov 2015-03-14 19:13:40 MSK
dkms compilation fail plymouth. 
But if the process successful (two reboot)  - it's no fatal, if sources is not setup - dkms compilation error fail plymouth complete.
Comment 2 Eugene Shatokhin 2015-03-16 11:12:09 MSK
As long as we support DKMS to build external kernel modules, -devel packages for the kernel must always be installed. So, most of the time, this is not a problem.

The real issues are in the dependencies of the services and the time intervals they are allowed to run. Someone needs to check and correct that.

http://bugs.rosalinux.ru/show_bug.cgi?id=4811 may be caused by a similar issue.
Comment 3 Eugene Shatokhin 2015-05-15 12:40:46 MSD
The recent updates of the kernel and dkms have significantly reduced the chance of this problem to happen. This is the most we can do at this point.