Bug 5171 - grub detect ROSA KDE5 as "unknown linux distribution"
: grub detect ROSA KDE5 as "unknown linux distribution"
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Konstantin Vlasov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-13 19:45 MSK by Vladimir Potapov
Modified: 2015-03-17 18:09 MSK (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
main grub (9.79 KB, application/octet-stream)
2015-03-17 17:28 MSK, Vladimir Potapov
Details
undetect grub 1 (9.76 KB, application/octet-stream)
2015-03-17 17:30 MSK, Vladimir Potapov
Details
undetect grub 2 (22.06 KB, application/octet-stream)
2015-03-17 17:32 MSK, Vladimir Potapov
Details
os-release undetected2 (277 bytes, application/octet-stream)
2015-03-17 17:34 MSK, Vladimir Potapov
Details
lsb-release undetected 2 (131 bytes, application/octet-stream)
2015-03-17 17:35 MSK, Vladimir Potapov
Details
system-release undetected 2 (46 bytes, application/octet-stream)
2015-03-17 17:35 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2015-03-13 19:45:01 MSK
grub detect ROSA KDE5 as "unknown linux distribution"
1) Set up ISO 9798 KDE x64 UEFI
2) See in grub menu "unknown linux distribution" for current KDE
Comment 1 Konstantin Vlasov 2015-03-13 20:12:54 MSK
Were there any other installed systems on the same computer? If yes, were they detected correctly?
Comment 2 Vladimir Potapov 2015-03-14 08:50:41 MSK
Fedora, detect correct
Comment 3 Konstantin Vlasov 2015-03-17 17:23:18 MSK
Cannot reproduce in VirtualBox. Is this "unknown linux" a newly installed (primary) system, or one of the already existing ones?

Please, provide the following files:
1. from both the primary system and the system which failed to detect:
 /boot/grub2/grub.cfg
2. from the system which failed to detect:
/etc/os-release
/etc/lsb-release
/etc/system-release

Also I'd like to take a look at the output of the "update-grub2" command.

If failed system is not primary, please, provide also the output of "os-prober" and "linux-boot-prober /dev/sdXY", where /dev/sdXY is the root partition of the failed system.
Comment 4 Vladimir Potapov 2015-03-17 17:28:41 MSK
Created attachment 3800 [details]
main grub
Comment 5 Vladimir Potapov 2015-03-17 17:30:33 MSK
Created attachment 3801 [details]
undetect grub 1
Comment 6 Vladimir Potapov 2015-03-17 17:32:37 MSK
Created attachment 3802 [details]
undetect grub 2
Comment 7 Vladimir Potapov 2015-03-17 17:34:01 MSK
Created attachment 3803 [details]
os-release undetected2
Comment 8 Vladimir Potapov 2015-03-17 17:35:07 MSK
Created attachment 3804 [details]
lsb-release undetected 2
Comment 9 Vladimir Potapov 2015-03-17 17:35:40 MSK
Created attachment 3805 [details]
system-release undetected 2
Comment 10 Vladimir Potapov 2015-03-17 17:38:31 MSK
# update-grub2
Генерируется grub.cfg …
Найдена тема: /boot/grub2/themes/rosa/theme.txt
Найден фон: /boot/grub2/themes/rosa/terminal_background.png
Найден образ linux: /boot/vmlinuz-3.14.33-nrj-desktop-1rosa
Найден образ initrd: /boot/initrd-3.14.33-nrj-desktop-1rosa.img
Найден образ linux: /boot/vmlinuz-3.14.33-desktop-1rosa
Найден образ initrd: /boot/initrd-3.14.33-desktop-1rosa.img
Найден ROSA Desktop Fresh R5 (2014.1) на /dev/sda2
Найден ROSA Desktop Fresh R5 (2014.1) на /dev/sda5
Найден ROSA Desktop Fresh R5 (2014.1) на /dev/sdb1
Найден Fedora release 21 (Twenty One) на /dev/sdb7
завершено
Comment 11 Vladimir Potapov 2015-03-17 17:42:25 MSK
After the command the issue fixed.
Maybe http://bugs.rosalinux.ru/show_bug.cgi?id=5142
Comment 12 Konstantin Vlasov 2015-03-17 18:09:39 MSK
It might be a temporarily inconsistent state of the target systems. As I can see, the lsb-release package now does not contain /etc/lsb-release file which is used by os-prober to get the OS name (and, since you are using linked mode, this name is then included into grub.cfg).

So, if you installed the new lsb-release, but did not install branding-configs (where the file /etc/lsb-release is recreated as a symlink), then this OS will be "unnamed" for os-prober.

For now I'm closing the bug, then. If you can reproduce it with fully updated systems, please, reopen it and provide the new information.