Bug 5164 - [UPDATE REQUEST] ffmpeg 2.3.6 -> 2.5.4 + libdvdread, libdvdnav, libdvdcss, mplayer, xbmc
: [UPDATE REQUEST] ffmpeg 2.3.6 -> 2.5.4 + libdvdread, libdvdnav, libdvdcss, mp...
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-13 09:53 MSK by Andrey Bondrov
Modified: 2015-03-27 20:02 MSK (History)
3 users (show)

See Also:
RPM Package: multimedia stack
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
ss (16.30 KB, text/x-log)
2015-03-14 07:42 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2015-03-13 09:53:17 MSK
We need to update multimedia stack.

Please test packages from http://abf-downloads.rosalinux.ru/ffmpeg_backports_personal/repository/rosa2014.1/
Comment 1 FirstLevel 2015-03-13 11:24:30 MSK
32 bit

install vlc, xbmc, xbmc-eventclient, linphone, libquicktime, libopencv, chromaprint, gegl & plug container & update - ok
plug container & update & install vlc, xbmc, xbmc-eventclient, linphone, libquicktime, libopencv, chromaprint, gegl - ok


64 bit

install vlc, xbmc, xbmc-eventclient, linphone, libquicktime, libopencv, chromaprint, gegl & plug container & update - ok
plug container & update & install vlc, xbmc, xbmc-eventclient, linphone, libquicktime, lib64opencv, chromaprint, gegl - ok
Comment 2 Vladimir Potapov 2015-03-14 07:42:29 MSK
Created attachment 3799 [details]
ss

XBMC crash when DVD play. X64 - hung without messages, i586 - crash with dump
Comment 3 Andrey Bondrov 2015-03-15 18:34:51 MSK
(In reply to comment #2)
> Created attachment 3799 [details]
> ss
> 
> XBMC crash when DVD play. X64 - hung without messages, i586 - crash with dump

I confirm. Let's see what we can do...
Comment 4 Andrey Bondrov 2015-03-15 21:13:05 MSK
(In reply to comment #2)
> Created attachment 3799 [details]
> ss
> 
> XBMC crash when DVD play. X64 - hung without messages, i586 - crash with dump

Looks like the crash was caused by dlopen loop. Perhaps x86_64 didn't crash because it could allocate more memory. So x86_64 version just takes more time to eventually crash. The fix is on the way.

BTW, likely older XBMC version in rosa2014.1 crashes on DVD playback as well. Please check it if you can. dlopen wrapper didn't change in XBMC 14.x so likely gcc optimizations caused the crash, not the code itself.
Comment 5 Andrey Bondrov 2015-03-15 21:59:21 MSK
Please update your system, the crash should be fixed in xbmc 14.2rc1 build. At least i586 version plays DVDs fine with my patch.
Comment 6 Vladimir Potapov 2015-03-16 18:29:16 MSK
http://abf-downloads.rosalinux.ru/ffmpeg_backports_personal/repository/rosa2014.1/
*******************
QA Verified