Bug 5159 - [UPDATE REQUEST] x11-driver-video-nouveau-1.0.11
: [UPDATE REQUEST] x11-driver-video-nouveau-1.0.11
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-11 12:38 MSK by Eugene Shatokhin
Modified: 2016-01-30 22:55 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2015-03-11 12:38:51 MSK
Updated x11-driver-video-nouveau to version 1.0.11.
Comment 1 Eugene Shatokhin 2015-03-11 12:47:47 MSK
Advisory:
The opensource X11 driver for NVidia GPUs that relies on nouveau was updated to version 1.0.11. This version adds support for "Maxwell" series GPUs and provides a number of bug fixes, including the fixes related to multi-monitor configurations.

Build lists:
i586:
https://abf.io/build_lists/2451991
x86_64:
https://abf.io/build_lists/2451992

Hints for testing
Besides testing the graphics with nouveau as usual, please look for regressions when an external monitor are used with a laptop.
Comment 2 Vladimir Potapov 2015-03-12 18:07:58 MSK
The update sent to expanded testing
***********************************
Comment 3 Andrey Ponomarenko 2015-03-12 19:09:36 MSK
ASUS EeePC 1015PN + R5 KDE i586

Before and after the update, the picture on the screen sometimes twinkles as noise in the analog TV signal. This behaviour was not reproduced on x86_64.

HW probe: http://hw.rosalinux.ru/index.php?probe=5a39262c43

//

До и после обновления изображение на экране иногда кратковременно пропадает и вновь появляется, как будто помехи аналогового сигнала телевизора. На x86_64 такое поведение не наблюдалось.
Comment 4 Andrey Ponomarenko 2015-03-12 21:20:53 MSK
Dell Latitude E6530 + R5 KDE x86_64 + Samsung TV via HDMI (as mirror of the notebook screen)

Boot, video, glxgears - Ok on both screens

The only issue is that sound from browser and other applications is going to the notebook speakers, not to the TV. However, the system sound effects (system start, warnings in dolphin, etc.) are going to the TV.

I've also changed the priority of the "GF108 High Definition Audio Controller" in the "Multimedia" settings, but this doesn't fix the issue.

HW probe before update: http://hw.rosalinux.ru/index.php?probe=1828772df3
HW probe after update:  http://hw.rosalinux.ru/index.php?probe=d260b74126
Comment 5 Eugene Shatokhin 2015-03-12 22:12:42 MSK
(In reply to comment #3)
> ASUS EeePC 1015PN + R5 KDE i586
> 
> Before and after the update, the picture on the screen sometimes twinkles as
> noise in the analog TV signal. This behaviour was not reproduced on x86_64.

I observed a probably similar issue on my ASUS Eee PC 1015PED with Intel graphics. It has been present for a long time. Not sure what causes it, hardware or software.
Comment 6 Vladimir Potapov 2015-03-16 11:22:35 MSK
I see random hung from firefox work with adobe flash by the driver
*******************************************************************
QA Denied
Comment 7 Eugene Shatokhin 2015-03-16 11:50:27 MSK
(In reply to comment #6)
> I see random hung from firefox work with adobe flash by the driver
> *******************************************************************
> QA Denied

Logs = ?

We cannot fix the problem without proper diagnostics, can we?
Comment 8 Vladimir Potapov 2015-03-16 12:02:33 MSK
(In reply to comment #7)
> (In reply to comment #6)
> > I see random hung from firefox work with adobe flash by the driver
> > *******************************************************************
> > QA Denied
> 
> Logs = ?
> 
> We cannot fix the problem without proper diagnostics, can we?
We cannot fix it, the package don't sent to repositories.
Comment 9 Denis Silakov 2016-01-30 22:55:40 MSK
We are at x11-driver-video-nouveau-1.0.11-2.20151117.2 after last X11 stack update.