Bug 5154 - [UPDATE REQUEST] acpid-2.0.23-1
: [UPDATE REQUEST] acpid-2.0.23-1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-10 18:16 MSK by Eugene Shatokhin
Modified: 2015-03-16 12:06 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2015-03-10 18:16:27 MSK
Updated acpid (ACPI event daemon) to version 2.0.23.
Comment 1 Eugene Shatokhin 2015-03-10 18:21:55 MSK
Advisory:
acpid was updated to version 2.0.23. Most significant changes since 2.0.17:
* Fixes for the systems with large numbers of input layer connections. Before these fixes, X11 server could block indefinitely on acpid.socket in some cases making the system unusable.
* Better error handling.
* Fix for the format of video/tabletmode event string. The previous formats caused X11 server to crash in certain cases.
* A few fixes for mute keys support.

Build lists:
i586:
https://abf.io/build_lists/2451661
x86_64:
https://abf.io/build_lists/2451662

Hints for testing
After the update and reboot, please check if there are any regressions with:
* suspend/resume
* reaction to laptop lid open/close
* reaction to plugging and unplugging the AC adapter
* changing screen brightness using keyboard (Fn+<key>) and the power managements applet.
Comment 2 FirstLevel 2015-03-12 10:05:46 MSK
Update goes well for 32bit and 64 bit.
Comment 3 FirstLevel 2015-03-12 12:16:55 MSK
32 bit real hardware laptop HP 6465b (AMDA4)

old


* suspend/resume - ok
* reaction to plugging and unplugging the AC adapter - ok
* changing screen brightness using keyboard (Fn+<key>) - ok
* changing screen brightness using the power managements applet - ok


new

* suspend/resume - ok
* reaction to plugging and unplugging the AC adapter - ok
* changing screen brightness using keyboard (Fn+<key>) - ok
* changing screen brightness using the power managements applet - ok
Comment 4 FirstLevel 2015-03-12 12:29:21 MSK
64 bit real hardware laptop HP 6465b (AMDA4)

old


* suspend/resume - ok
* reaction to plugging and unplugging the AC adapter - ok
* changing screen brightness using keyboard (Fn+<key>) - ok
* changing screen brightness using the power managements applet - ok


new

* suspend/resume - ok
* reaction to plugging and unplugging the AC adapter - ok
* changing screen brightness using keyboard (Fn+<key>) - ok
* changing screen brightness using the power managements applet - ok
Comment 5 Vladimir Potapov 2015-03-12 15:24:16 MSK
The update sent to expanded testing
***********************************
QA Verified
Comment 6 Vladimir Potapov 2015-03-12 15:27:15 MSK
(In reply to comment #5)
> ***********************************
> QA Verified
^^^Sorry, QA will be after expanded testing
Comment 7 Vladimir Potapov 2015-03-16 11:17:03 MSK
acpid-2.0.23-1
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2451661/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2451662/x86_64/main/release/
************************* Advisory **************************
acpid was updated to version 2.0.23. Most significant changes since 2.0.17:
* Fixes for the systems with large numbers of input layer connections. Before these fixes, X11 server could block indefinitely on acpid.socket in some cases making the system unusable.
* Better error handling.
* Fix for the format of video/tabletmode event string. The previous formats caused X11 server to crash in certain cases.
* A few fixes for mute keys support.
************************************************************
QA Verified