Bug 5153 - arduino does not start with java errors
: arduino does not start with java errors
Status: RESOLVED DUPLICATE of bug 5043
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-09 19:53 MSK by andrea_scopelliti
Modified: 2016-11-20 14:30 MSK (History)
1 user (show)

See Also:
RPM Package: arduino 1.0.5 does not start with java errors
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andrea_scopelliti 2015-03-09 19:53:20 MSK
Description of problem:
After launching Arduino appears request to select the location of the destination foder appears. When you press the ok button the window closes and nothing else appears.
If launched from Konsole the following java errors are listed:
[andrea@DESKTOP-1 ~]$ arduino

(java:20610): Gtk-WARNING **: Theme directory 16x16/social of theme rosa has no size field


(java:20610): Gtk-WARNING **: Theme directory  of theme rosa has no size field


(java:20610): Gtk-WARNING **: Theme directory 112x112/apps of theme rosa has no size field

Exception in thread "main" java.lang.NoClassDefFoundError: gnu/io/CommPortIdentifier
        at processing.app.Editor.populateSerialMenu(Editor.java:989)
        at processing.app.Editor.buildToolsMenu(Editor.java:692)
        at processing.app.Editor.buildMenuBar(Editor.java:477)
        at processing.app.Editor.<init>(Editor.java:206)
        at processing.app.Base.handleOpen(Base.java:705)
        at processing.app.Base.handleOpen(Base.java:670)
        at processing.app.Base.handleNew(Base.java:566)
        at processing.app.Base.<init>(Base.java:306)
        at processing.app.Base.main(Base.java:195)
Caused by: java.lang.ClassNotFoundException: gnu.io.CommPortIdentifier
        at java.net.URLClassLoader$1.run(URLClassLoader.java:372)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:360)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        ... 9 more

The installed version of java is: java-1.8.0-openjdk 1.8.0.5-4.b13-rosa2014.1. x64


Version-Release number of selected component (if applicable):
1.0.5-6-rosa2014.1

How reproducible:
launch arduino either from rosapanel or from konsole

Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Silakov 2016-11-20 14:30:35 MSK

*** This bug has been marked as a duplicate of bug 5043 ***