Bug 5150 - Pulseaudio 6.0 does not autostart itself
: Pulseaudio 6.0 does not autostart itself
Status: RESOLVED NOTABUG
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Highest critical
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-09 18:50 MSK by Giovanni Mariani
Modified: 2015-03-09 19:21 MSK (History)
0 users

See Also:
RPM Package: pulseaudio-6.0-1.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2015-03-09 18:50:12 MSK
Description of problem:
Since the latest 5.0 -> 6.0 upgrade, pulseaudio does not start at the KDE starting time.
Symptoms:
* no KDE audio starting sound
* Kmix does not show the installed sound card (SB Audigy 2ZS Platinum Pro)
* the Multimedia applet - Audio and Video Settings in KDE SystemSettings does not show the Audio Hardware Setup tab
* (obviously) no audio in any app.

Workaround: manually launch "pulseaudio --start" from a Konsole and reload Kmix to gain the new mixer entries.

No interesting output in journal; only the lines below, reporting errors from module-jackdbus-detect
and warnings from the deprecated module-dbus-protocol and module-equalizer-sink:
************************************
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	Default and alternate sample rates are the same.
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	Failed to parse channels= argument.
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	Failed to load module "module-jackdbus-detect" (argument: ""): initialization failed.
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	module-dbus-protocol is currently unsupported, and can sometimes cause PulseAudio crashes.
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	The most popular use cases for module-dbus-protocol are related to changing equalizer settings and LADSPA plugin parameters at runtime.
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	If you don't use such functionality, it's possible that you don't actually need this module.
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	module-equalizer-sink is currently unsupported, and can sometimes cause PulseAudio crashes, increased latency or audible artifacts.
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	If you're facing audio problems, try unloading this module as a potential workaround.
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	Default and alternate sample rates are the same.
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	Module load failed.
09/03/2015 15:13:15	Rivendell	pulseaudio[13695]	org.bluez.Manager.GetProperties() failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" with signature "" on interface "org.bluez.Manager" doesn't exist
************************************

The pulseaudio.desktop in /etc/xdg/autostart seems not executed or at least not without errors:
running manually from a konsole the start-pulseaudio-x11 script it references (both as normal user and as root)
ends up in a couple of error messages:
*****************
Connection failure: Connection refused
pa_context_connect() failed: Connection refused
*****************


Version-Release number of selected component (if applicable):
6.0-1

How reproducible:
Always.

Steps to Reproduce:
1. Update to the latest pulseaudio from Main updates
2. Reboot
3. Login
4. No sound
Comment 1 Giovanni Mariani 2015-03-09 19:21:54 MSK
OK.
Found the culprit:
somehow I managed to have "autospawn=no" in the client.conf file and that, according to the release notes of PA 6.0, would end in PA not starting automatically...

Still I can't remember why was the setting here or when I inserted it.

Anyway, not a package bug: closing and sorry for the fuss.