Bug 5145 - [UPDATE REQUEST] urpmi-7.32.3-39
: [UPDATE REQUEST] urpmi-7.32.3-39
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal critical
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-06 21:20 MSK by Konstantin Vlasov
Modified: 2015-03-11 16:07 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
firstlevel: qa_verified+
denis.silakov: published+


Attachments
new-urpmi-32.jpg (88.57 KB, image/jpeg)
2015-03-11 15:25 MSK, FirstLevel
Details
new-urpmi-64.jpg (100.58 KB, image/jpeg)
2015-03-11 15:25 MSK, FirstLevel
Details
old-urpmi-32.jpg (86.82 KB, image/jpeg)
2015-03-11 15:26 MSK, FirstLevel
Details
old-urpmi-64.jpg (100.21 KB, image/jpeg)
2015-03-11 15:26 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2015-03-06 21:20:22 MSK
Bug fixed in urpmi: "non-free testing" was not ignored by default. Now all media of type backports, debug, source, or testing, will be ignored by default.
Comment 1 Konstantin Vlasov 2015-03-06 21:31:05 MSK
https://abf.rosalinux.ru/build_lists/2452021
https://abf.rosalinux.ru/build_lists/2452022

Advisory: Fixed not ignoring one of the testing media by default.

How to test: run command (depending on your OS architecture)
  urpmi.addmedia --distrib http://abf-downloads.rosalinux.ru/rosa2014.1/repository/x86_64/
or
  urpmi.addmedia --distrib http://abf-downloads.rosalinux.ru/rosa2014.1/repository/i586/

Currently there are 3 testing media for x86_64, and 2 testing media for i586. They must be ignored by default.
Comment 2 Denis Silakov 2015-03-07 00:42:18 MSK
Hm. Actually processing of 'testing' repositories is supposed to be controlled by media.cfg file (http://abf-downloads.rosalinux.ru/rosa2014.1/repository/i586/media/media_info/media.cfg) by "noauto" parameter. With this parameter, urpmi adds the media but marks it as ignored, so users can simply enable it in future.

As far as I understand with this patch urpmi will not the testing media at all. I think this is not the desired behavior.

Or something was wrong with urpmi and "noauto" didn't work for some reason? Up to now it seemed to work fine with 'main testing'...
Comment 3 Denis Silakov 2015-03-07 01:14:16 MSK
Indeed, I have run "urpmi.addmedia --distrib http://abf-downloads.rosalinux.ru/rosa2014.1/repository/x86_64/" now (without the patch) and got 'main testing' and 'main testing32' marked as ignored, but "non-free testing" as enabled.

I think that the issue lies in some other place and the patch suggested is just a workaround. Though it can be used as a hot fix.
Comment 4 Konstantin Vlasov 2015-03-07 01:24:41 MSK
The cause of the problem is, noauto is indeed the controller, but it is overridden by the new set of rules which tells: if this is a "non-free" - shut up and add it, no matter what:
https://abf.rosalinux.ru/import/urpmi/blob/rosa2014.1/urpmi-7.32.2-rosa-release.patch#lc-31

Maybe the patch should be rewritten so that the function returned immediately if "noauto" check was positive, or move the noauto check after the edition-specific regulations, or any other way you feel the best. I just did it the easiest way, by copying the old code (now removed by the patch quoted above) which had been excluding non-regular media.

The issue is quite dangerous: at the moment, urpmi keeps enabling "non-free testing" for all users who add new set of repositories, so this should be fixed ASAP, one way or another.
Comment 5 Denis Silakov 2015-03-07 01:35:19 MSK
Ah, yes, I have also took a look at that code:) 

This mess comes from old Mandriva and is not actual for ROSA now, since we have dropped separation on 'EE' and 'CE' three years ago (not speaking about 'GE' and separate conditions for 'LXDE'). 

Let's leave this patch for now then. When I have time, I will simply drop the rosa-release patch together with the code which is dropped by that patch and make is_media_to_add_by_default() to simply return $add_by_default.
Comment 6 Denis Silakov 2015-03-10 13:45:31 MSK
Here are the new build lists - rosa-release patch has been dropped completely,  urpmi now simply follows instructions from media.cfg.

https://abf.io/build_lists/2452272
https://abf.io/build_lists/2452273

As a result, non-free-testing repository should be added with "Ignore" flag when you add repos with "--distrib".
Comment 7 FirstLevel 2015-03-10 17:22:16 MSK
plug container and update newly installed R5 32bit and reboot - ok
plug container and update newly installed R5 64bit and reboot - ok
Comment 8 FirstLevel 2015-03-11 15:25:45 MSK
Created attachment 3792 [details]
new-urpmi-32.jpg
Comment 9 FirstLevel 2015-03-11 15:25:58 MSK
Created attachment 3793 [details]
new-urpmi-64.jpg
Comment 10 FirstLevel 2015-03-11 15:26:10 MSK
Created attachment 3794 [details]
old-urpmi-32.jpg
Comment 11 FirstLevel 2015-03-11 15:26:25 MSK
Created attachment 3795 [details]
old-urpmi-64.jpg
Comment 12 FirstLevel 2015-03-11 15:28:37 MSK
I have testes such cases.
1. Remove all sources.
2. Execute commands 
  urpmi.addmedia --distrib http://abf-downloads.rosalinux.ru/rosa2014.1/repository/x86_64/
or
  urpmi.addmedia --distrib http://abf-downloads.rosalinux.ru/rosa2014.1/repository/i586/
3. See what happens

Resuts for 
32bit old urpmi - old-urpmi-32.jpg
32bit new urpmi - new-urpmi-32.jpg
64bit old urpmi - old-urpmi-64.jpg
64bit new urpmi - new-urpmi-64.jpg

"Now all media of type backports, debug, source, or testing, will be ignored by default." - it works
Comment 13 FirstLevel 2015-03-11 15:50:43 MSK
urpmi-7.32.3-40
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2452273/x86_64/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2452272/i586/main/release/
************************ Advisory **********************
Currently there are 3 testing media for x86_64, and 2 testing media for i586. They must be ignored by default.
********************************************************
QA Verified