Bug 5140 - [UPDATE REQUEST] nvidia-current 346.47
: [UPDATE REQUEST] nvidia-current 346.47
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Low normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-04 21:21 MSK by Eugene Shatokhin
Modified: 2015-03-16 12:06 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2015-03-04 21:21:51 MSK
Updating nvidia-current to the latest upstream version. 

This is a low-priority update because nvidia-current is not recommended for everyday use.

If there are users with GPUs older than GeForce GTX 400 using nvidia-current, well, they have been warned. They should use what XFdrake suggests instead.
Comment 1 Eugene Shatokhin 2015-03-04 21:30:16 MSK
Advisory:
New upstream version, 346.x. Supports GeForce GTX 400 series and newer GPUs and contains many enhancements and fixes, including but not limited to:
* the ability to increase the operating voltage on certain GeForce GPUs;
* support for decoding VP8 video streams using the NVCUVID API;
* accelerated support for r8g8b8a8, r8g8b8x8, b8g8r8a8 and b8g8r8x8 RENDER formats.

Build lists:
i586: 
https://abf.io/build_lists/2451200

x86_64:
https://abf.io/build_lists/2451201

Notes

1. libvdpau 0.9 (http://bugs.rosalinux.ru/show_bug.cgi?id=5108) is needed for this update.

2. Supported GPUs are the same as for nvidia346:
https://abf.io/soft/ldetect-lst/blob/0.1.329/drivers/README-nvidia346.txt#lc-6632

Do not use nvidia-current with GPUs it does not support. The update will cause problems in that case. That is why we do not recommend to use nvidia-current except for experiments, debugging, etc.

3. We do not support hybrid graphics officially with nvidia-current.
Comment 2 Eugene Shatokhin 2015-03-04 21:33:43 MSK
How to test

1. If there are proprietary NVidia drivers used on the system, please run XFdrake first to switch to nouveau.

XFdrake will not propose nvidia-current for the reasons I described in a previous comment.

2. Install/update x11-driver-video-nvidia-current and dkms-nvidia-current.

If other NVidia drivers are installed, they will be removed now.

3. Reboot.
Comment 3 Eugene Shatokhin 2015-03-04 21:36:13 MSK
To uninstall the driver, remove x11-driver-video-nvidia-current and dkms-nvidia-current packages, then reboot.
Comment 4 Vladimir Potapov 2015-03-12 11:57:58 MSK
The update sent to expanded testing
*************************************
Comment 5 Vladimir Potapov 2015-03-16 11:28:06 MSK
nvidia-current-346.47-1
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2451200/i586/non-free/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2451201/x86_64/non-free/release/
******************************** Advisory **************************
New upstream version, 346.x. Supports GeForce GTX 400 series and newer GPUs and contains many enhancements and fixes, including but not limited to:
* the ability to increase the operating voltage on certain GeForce GPUs;
* support for decoding VP8 video streams using the NVCUVID API;
* accelerated support for r8g8b8a8, r8g8b8x8, b8g8r8a8 and b8g8r8x8 RENDER formats.
*******************************************************************
QA Verified