Bug 5139 - [UPDATE REQUEST] libreoffice 4.3.5 -> 4.4.2
: [UPDATE REQUEST] libreoffice 4.3.5 -> 4.4.2
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-04 18:04 MSK by Andrey Bondrov
Modified: 2015-04-20 16:53 MSD (History)
5 users (show)

See Also:
RPM Package: libreoffice
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
kuzma.kazygashev: secteam_verified+
denis.silakov: published+


Attachments
translation problems LO Writer (451.86 KB, application/octet-stream)
2015-03-06 11:03 MSK, FirstLevel
Details
impress-vstavka-textbox.jpg (138.82 KB, image/jpeg)
2015-03-06 11:15 MSK, FirstLevel
Details
draw-vstavka-textbox.jpg (110.59 KB, image/jpeg)
2015-03-06 11:19 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2015-03-04 18:04:39 MSK
New major version of LibreOffice was released.
Comment 1 Andrey Bondrov 2015-03-04 18:10:07 MSK
libcmis:
Advisory: "New version 0.5.0 needed for LibreOffice 4.4.1"
https://abf.rosalinux.ru/build_lists/2451062
https://abf.rosalinux.ru/build_lists/2451063

libmwaw:
Advisory: "New version 0.3.4 needed for LibreOffice 4.4.1"
https://abf.rosalinux.ru/build_lists/2451058
https://abf.rosalinux.ru/build_lists/2451059

LibreOffice: "New version 4.4.1.2"
https://abf.rosalinux.ru/build_lists/2451071
https://abf.rosalinux.ru/build_lists/2451072
Comment 2 FirstLevel 2015-03-06 10:48:08 MSK
Update goes well for 32 and 64 bit.
Launching all LO - OK
Version - OK
Comment 3 FirstLevel 2015-03-06 11:03:00 MSK
LO Writer

localization degradation:
old - oldlo-tablica-videlit.jpg oldlo-tablica-udalit-tablica.jpg
new - lo-tablica-udalit-table.jpg lo-tablica-videlit.jpg

new non-translated items
lo-VID-Images.jpg lo-vstavka-shapes.jpg
Comment 4 FirstLevel 2015-03-06 11:03:47 MSK
Created attachment 3786 [details]
translation problems LO Writer
Comment 5 FirstLevel 2015-03-06 11:15:02 MSK
LO Impress

new non-translated items
impress-vstavka-textbox.jpg
Comment 6 FirstLevel 2015-03-06 11:15:17 MSK
Created attachment 3787 [details]
impress-vstavka-textbox.jpg
Comment 7 FirstLevel 2015-03-06 11:19:13 MSK
LO Draw


new non-translated itesm
draw-vstavka-textbox.jpg
Comment 8 FirstLevel 2015-03-06 11:19:26 MSK
Created attachment 3788 [details]
draw-vstavka-textbox.jpg
Comment 9 Andrey Bondrov 2015-03-06 13:20:08 MSK
I see, let's wait for LO 4.4.1.3 then...
Comment 10 FirstLevel 2015-03-06 16:40:38 MSK
************************ Advisory **********************
Localization issues
********************************************************
QA Denied
Comment 11 JDronova 2015-03-29 19:07:14 MSD
(In reply to comment #10)
> ************************ Advisory **********************
> Localization issues
> ********************************************************
> QA Denied

There was a number of bugs related to those localization issues, they are code problems not localization itself: https://bugs.documentfoundation.org/buglist.cgi?bug_status=RESOLVED&component=Localization&product=LibreOffice&resolution=FIXED&short_desc=Untranslatable&short_desc_type=anywords

Those fixed issues will be available in the 4.4.2 release, so we can do nothing here but wait for the release to come.
Comment 12 Andrey Bondrov 2015-04-04 03:40:28 MSD
libcmis:
Advisory: "New version 0.5.0 needed for LibreOffice 4.4.1"
https://abf.rosalinux.ru/build_lists/2487387
https://abf.rosalinux.ru/build_lists/2487388

libmwaw:
Advisory: "New version 0.3.4 needed for LibreOffice 4.4.1"
https://abf.rosalinux.ru/build_lists/2487385
https://abf.rosalinux.ru/build_lists/2487386

LibreOffice: "New version 4.4.2.2"
https://abf.rosalinux.ru/build_lists/2487440
https://abf.rosalinux.ru/build_lists/2487441
Comment 13 FirstLevel 2015-04-06 15:58:35 MSD
(In reply to comment #12)
> libcmis:
> Advisory: "New version 0.5.0 needed for LibreOffice 4.4.1"
> https://abf.rosalinux.ru/build_lists/2487387
> https://abf.rosalinux.ru/build_lists/2487388
> 
> libmwaw:
> Advisory: "New version 0.3.4 needed for LibreOffice 4.4.1"
> https://abf.rosalinux.ru/build_lists/2487385
> https://abf.rosalinux.ru/build_lists/2487386
> 
> LibreOffice: "New version 4.4.2.2"
> https://abf.rosalinux.ru/build_lists/2487440
> https://abf.rosalinux.ru/build_lists/2487441

--1--
For 64 bit I see such errors while updating:
Подготовка...                    ###################################################################################################################
     1/16: libreoffice-common    ###################################################################################################################
update-alternatives: warning: alternative /usr/lib64/libreoffice/program/libnpsoplugin.so (part of link group libnpsoplugin.so) doesn't exist; removing from list of alternatives
update-alternatives: warning: /etc/alternatives/libnpsoplugin.so is dangling; it will be updated with best choice
update-alternatives: error: alternative path /usr/lib64/libreoffice/program/libnpsoplugin.so doesn't exist
ERROR: 'script' failed for libreoffice-common-4.4.2-2-rosa2014.1.x86_64: 
error: %post(libreoffice-common-4.4.2-2.x86_64) scriptlet failed, exit status 2
     2/16: libreoffice-help-en_US

Is it important?
For 32bit I have no any errors during update.

--2--
And for 32bit I have plugged 3 containers and urpmi --auto-update use all of them
For 64 I have plugged 3 containers and urpmi --auto-update use only container with LO.
Comment 14 Andrey Bondrov 2015-04-06 16:18:44 MSD
(In reply to comment #13)
> ERROR: 'script' failed for libreoffice-common-4.4.2-2-rosa2014.1.x86_64: 
> error: %post(libreoffice-common-4.4.2-2.x86_64) scriptlet failed, exit
> status 2
> 
> Is it important?

Seems to be important. Perhaps libnpsoplugin.so was moved to another package.

Can you please run this command for new 32 bit LO?

rpm -qf /usr/lib/libreoffice/program/libnpsoplugin.so

> For 64 I have plugged 3 containers and urpmi --auto-update use only
> container with LO.

There's a chance that you have packages from other containers already installed (lib64cmis0.5_5 and others).
Comment 15 FirstLevel 2015-04-06 21:31:22 MSD
(In reply to comment #14)
> (In reply to comment #13)
> > ERROR: 'script' failed for libreoffice-common-4.4.2-2-rosa2014.1.x86_64: 
> > error: %post(libreoffice-common-4.4.2-2.x86_64) scriptlet failed, exit
> > status 2
> > 
> > Is it important?
> 
> Seems to be important. Perhaps libnpsoplugin.so was moved to another package.
> 
> Can you please run this command for new 32 bit LO?
> 
> rpm -qf /usr/lib/libreoffice/program/libnpsoplugin.so
> 
[root@r5-32 ~]# rpm -qf /usr/lib/libreoffice/program/libnpsoplugin.so
файл /usr/lib/libreoffice/program/libnpsoplugin.so: Нет такого файла или каталога
[root@r5-32 ~]# 

[root@r5-32 ~]# rpm -qa | grep libre
libreadline6-6.3-4-rosa2014.1.i586
libreport0-2.0.10-9-rosa2014.1.i586
libredland0-1.0.16-2-rosa2014.1.i586
libdjvulibre21-3.5.25.3-2-rosa2014.1.i586
librevenge0.0_0-0.0.1-1-rosa2014.1.i586
djvulibre-3.5.25.3-2-rosa2014.1.i586
libregistry0-4.1.17-5-rosa2014.1.i586
libreoffice-common-4.4.2-2-rosa2014.1.i586
libreoffice-help-en_US-4.4.2-2-rosa2014.1.i586
libreoffice-style-oxygen-4.4.2-2-rosa2014.1.i586
libreoffice-l10n-en_GB-4.4.2-2-rosa2014.1.i586
libreoffice-help-ru-4.4.2-2-rosa2014.1.i586
libreoffice-l10n-ru-4.4.2-2-rosa2014.1.i586
libreoffice-help-en_GB-4.4.2-2-rosa2014.1.i586
libreoffice-draw-4.4.2-2-rosa2014.1.i586
libreoffice-writer-4.4.2-2-rosa2014.1.i586
libreoffice-math-4.4.2-2-rosa2014.1.i586
libreoffice-gnome-4.4.2-2-rosa2014.1.i586
libreoffice-calc-4.4.2-2-rosa2014.1.i586
libreoffice-style-galaxy-4.4.2-2-rosa2014.1.i586
libreoffice-style-crystal-4.4.2-2-rosa2014.1.i586
libreoffice-impress-4.4.2-2-rosa2014.1.i586
libreoffice-kde4-4.4.2-2-rosa2014.1.i586
[root@r5-32 ~]#
Comment 16 Andrey Bondrov 2015-04-06 22:15:34 MSD
(In reply to comment #15)
> [root@r5-32 ~]# rpm -qf /usr/lib/libreoffice/program/libnpsoplugin.so
> файл /usr/lib/libreoffice/program/libnpsoplugin.so: Нет такого файла или
> каталога

Thanx. I found that the browser plugin was removed upstream in LibreOffice 4.4+: https://skyfromme.wordpress.com/2014/09/25/killing-the-npapi-plugin/

So I'll have to drop post script from our packages.
Comment 17 Andrey Bondrov 2015-04-07 11:19:11 MSD
libcmis:
Advisory: "New version 0.5.0 needed for LibreOffice 4.4.1"
https://abf.rosalinux.ru/build_lists/2487387
https://abf.rosalinux.ru/build_lists/2487388

libmwaw:
Advisory: "New version 0.3.4 needed for LibreOffice 4.4.1"
https://abf.rosalinux.ru/build_lists/2487385
https://abf.rosalinux.ru/build_lists/2487386

LibreOffice: "New version 4.4.2.2. NPAPI browser plugin is no longer provided by upstream"
https://abf.rosalinux.ru/build_lists/2488237
https://abf.rosalinux.ru/build_lists/2488238
Comment 18 FirstLevel 2015-04-07 12:12:53 MSD
(In reply to comment #17)
> libcmis:
> Advisory: "New version 0.5.0 needed for LibreOffice 4.4.1"
> https://abf.rosalinux.ru/build_lists/2487387
> https://abf.rosalinux.ru/build_lists/2487388
> 
> libmwaw:
> Advisory: "New version 0.3.4 needed for LibreOffice 4.4.1"
> https://abf.rosalinux.ru/build_lists/2487385
> https://abf.rosalinux.ru/build_lists/2487386
> 
> LibreOffice: "New version 4.4.2.2. NPAPI browser plugin is no longer
> provided by upstream"
> https://abf.rosalinux.ru/build_lists/2488237
> https://abf.rosalinux.ru/build_lists/2488238

No errors occurred while updating on 32 and 64 bit
Comment 19 FirstLevel 2015-04-07 14:20:50 MSD
All non-translated items are translated

lo-VID-Images.jpg - fixed
lo-vstavka-shapes.jpg - fixed
lo-tablica-udalit-table.jpg - fixed
lo-tablica-videlit.jpg - fixed
impress-vstavka-textbox.jpg - fixed
draw-vstavka-textbox.jpg - fixed
Comment 20 Vladimir Potapov 2015-04-08 16:09:32 MSD
Хотелось бы исправить работу с удаленными файлами по ftp (русские имена) 
http://bugs.rosalinux.ru/show_bug.cgi?id=4353
и по самбе http://bugs.rosalinux.ru/show_bug.cgi?id=5361
Comment 21 Vladimir Potapov 2015-04-09 14:17:26 MSD
(In reply to comment #20)
> Хотелось бы исправить работу с удаленными файлами по ftp (русские имена) 
> http://bugs.rosalinux.ru/show_bug.cgi?id=4353
> и по самбе http://bugs.rosalinux.ru/show_bug.cgi?id=5361

Попробовал WebDAV с яндексом. Dolphin открывает как с %U, так и с %F.
Из диалога открытия пытается открыть, но получает чистый лист
Comment 22 Vladimir Potapov 2015-04-09 14:24:10 MSD
Нашел в чем причина ошибок. %F вызывает копирование и редактирование локальной копии, что проще и потому ошибок меньше.
прописаны X-KDE-Protocols=file,http,ftp,webdav 
и с этим протоколами LO должен работать удаленно, без копирования.
Но, однако ж, работает не всегда.
Comment 23 Andrey Bondrov 2015-04-09 14:54:02 MSD
Сдаётся мне, что копирование может обернуться проблемами, когда пользователь вроде сохранил изменённый файл, а он куда-нибудь во временный каталог попал в итоге, а оригинальный файл остался без изменений. Или такого не наблюдается?
Comment 24 Vladimir Potapov 2015-04-09 15:06:57 MSD
(In reply to comment #23)
> Сдаётся мне, что копирование может обернуться проблемами, когда пользователь
> вроде сохранил изменённый файл, а он куда-нибудь во временный каталог попал
> в итоге, а оригинальный файл остался без изменений. Или такого не
> наблюдается?
Там предлагается его закачать.

ДОбавил баг про WebDAV http://bugs.rosalinux.ru/show_bug.cgi?id=5369
Comment 25 Vladimir Potapov 2015-04-09 15:08:57 MSD
Итого, похоже, три проблемы
1) с FTP - лечится %U-%F
2) c OpenDialog - не нашел как
3) с WebDAV при открытии через OpenDialog - не нашел, как.
Comment 26 Andrey Bondrov 2015-04-14 11:05:00 MSD
libcmis:
Advisory: "New version 0.5.0 needed for LibreOffice 4.4.2"
https://abf.rosalinux.ru/build_lists/2487387
https://abf.rosalinux.ru/build_lists/2487388

libmwaw:
Advisory: "New version 0.3.4 needed for LibreOffice 4.4.2"
https://abf.rosalinux.ru/build_lists/2487385
https://abf.rosalinux.ru/build_lists/2487386

LibreOffice: "New version 4.4.2.2. NPAPI browser plugin is no longer provided by upstream. Improve work with some protocols (smb, remote etc)"
https://abf.rosalinux.ru/build_lists/2490119
https://abf.rosalinux.ru/build_lists/2490120
Comment 27 Vladimir Potapov 2015-04-14 20:37:27 MSD
The update is sent to expanded testing
****************************************
Comment 28 Vladimir Potapov 2015-04-20 10:48:48 MSD
libcmis-0.5.0-1
https://abf.rosalinux.ru/build_lists/2487387
https://abf.rosalinux.ru/build_lists/2487388

libmwaw-0.3.4-1
https://abf.rosalinux.ru/build_lists/2487385
https://abf.rosalinux.ru/build_lists/2487386

libreoffice-4.4.2-2.2
https://abf.rosalinux.ru/build_lists/2490119
https://abf.rosalinux.ru/build_lists/2490120
***************** Advisory ********************
libcmis:New version 0.5.0 needed for LibreOffice 4.4.2
libmwaw:New version 0.3.4 needed for LibreOffice 4.4.2

libreoffice: New version 4.4.2.2. NPAPI browser plugin is no longer provided by upstream. Improve work with some protocols (smb, remote etc)
***********************************************
QA Verified