Bug 5125 - drakx-net does not configure WPA Enterprise connections correctly.
: drakx-net does not configure WPA Enterprise connections correctly.
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: -Enter Bugs Here-
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Desktop Triage Team
: Desktop Triage Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-03 06:09 MSK by Zombie Ryushu
Modified: 2015-03-05 18:32 MSK (History)
2 users (show)

See Also:
RPM Package: drakxtools
ISO-related:
Bad POT generating:
Upstream:


Attachments
WPA Supplicant Patch. (969 bytes, text/plain)
2015-03-03 06:09 MSK, Zombie Ryushu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2015-03-03 06:09:38 MSK
Created attachment 3777 [details]
WPA Supplicant Patch.

Description of problem:
When using mcc to configure WPA Enterprise connections the following occurs:

1. If a user enters a private key password it is shown on screen.

This is inconvenient, as a unprivileged user could see the password as it's being typed in or copied. Considering that mcc hides the other passwords, it may as well hide this one. (Consistency.)

2. If a user configures the following: Private key, Private key password, or a CA cert they are not saved as strings in /etc/wpa_supplicant.conf.

This means that the connection will not come up as wpa_supplicant will not parse the private key password, or the paths correctly, and will not load them as a result. 

I'm attaching a patch that fixes the above.


How reproducible:
Always.

Steps to Reproduce:
1. Open mcc
2. Try to configure a WPA Enterprise network.
3. Watch the connection not come up. (And the password has been exposed.)

This is part of the initiative to support FreeRadius, Samba 4, and OpenLDAP  based applications better. For that reason, this is being CCed to the Samba 4 Maintainer  working on both Samba 4 and OpenLDAP.
Comment 1 Denis Silakov 2015-03-03 18:31:10 MSK
Hm, are you sure you have drakx-net from ROSA installed? It looks like you have openmandriva/cooker package.

In ROSA, we prefer to use NetworkManager instead of mcc and drakx-net. So we haven't updated drakx-net for a long time and have older version than OpenMandriva (so I can't even find the lines like "EAP client private key password" in our drakx-net).
Comment 2 Zombie Ryushu 2015-03-04 10:04:45 MSK
You are Correct. Can the Patch be Re-assigned?
Comment 3 Denis Silakov 2015-03-05 18:32:22 MSK
It's better to file a separate bug in OpenMandriva bgz then - https://issues.openmandriva.org/