Bug 5124 - scannerdrake does not allow the user to manually set overrides for sane
: scannerdrake does not allow the user to manually set overrides for sane
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: -Enter Bugs Here-
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Desktop Triage Team
: Desktop Triage Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-03 05:53 MSK by Zombie Ryushu
Modified: 2015-03-03 05:53 MSK (History)
1 user (show)

See Also:
RPM Package: drakxtools
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2015-03-03 05:53:14 MSK
Some scanners need overrides set in sane's configuration for them to work properly.

(For example my ScanMagic 1200 UB Plus needs override "mustek-scanexpress-1200-ub-plus" otherwise xsane and friends will fail to connect to it. This is not set by mcc.)

Some scanners should be auto-detected, as mcc already attempts to detect the scanner. However considering that these scanners may use the same usb vendor and product ids, it would be nice to have an option to manually set the overrides in mcc. (As it seems proper auto-detection of the device may not be possible.)

This would prevent a user complaining about a device not working after using mcc to configure it and it's firmware. (If needed.) 

As it is, a user may need to lookup the sane back end's documentation to figure out why it does not work, and alter the config files manually. Even if the scanner was auto-detected.