Bug 511 - fltk library have unsatisfied dependencies
: fltk library have unsatisfied dependencies
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 21:24 MSD by Anton Chernyshov
Modified: 2013-04-09 19:33 MSD (History)
3 users (show)

See Also:
RPM Package: fltk-1.3.0-4-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Chernyshov 2012-07-11 21:24:23 MSD
Description of problem:
fltk library have unsatisfied dependencies

How reproducible:
Always

Installation of fltk raises following error:
LC_ALL=C sudo urpmi fltk
A requested package cannot be installed:
fltk-1.3.0-4-rosa.lts2012.0.x86_64 (due to unsatisfied libpng15.so.15()(64bit))
Continue installation anyway? (Y/n) 

This error makes impossible fgrun package building.
Comment 1 Dmitry Mikhirev 2012-08-03 13:27:34 MSD
The reason is that newer version of fltk with broken dependencies is present in contrib while the older version with correct dependencies is in main.

fltk packages should be removed from contrib.
Comment 2 Denis Silakov 2013-04-09 19:33:38 MSD
The problematic packages have been removed from repositories.