Bug 5084 - Intel Wireless 7260 doesn't work on ASUS B551
: Intel Wireless 7260 doesn't work on ASUS B551
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Hardware
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Groups for solving hardware issues.
: Eugene Shatokhin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-20 19:16 MSK by Andrey Ponomarenko
Modified: 2015-04-28 17:40 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2015-02-20 19:16:53 MSK
Description of problem:

The Intel Wireless 7260 card doesn't work on ASUS B551.

It is impossible to enable wireless in the network manager.

Forum topic: http://forum.rosalab.ru/viewtopic.php?f=53&t=5226

HW probe: http://hw.rosalinux.ru/index.php?probe=dca7a0968b

rfkill list:

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
2: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no


Version-Release number of selected component (if applicable): R5


How reproducible: always


Steps to Reproduce:
1.
2.
3.
Comment 1 Andrey Ponomarenko 2015-02-20 19:25:30 MSK
The file /etc/modprobe.d/blacklist-acer.conf with content:

  blacklist acer_wmi

removes the blocking, but it's still impossible to connect because of:

  wlan0: authentication with 00:1b:11:89:59:40 timed out

Probe: http://hw.rosalinux.ru/index.php?probe=7fb83818e3
Comment 2 Andrey Ponomarenko 2015-02-20 19:27:46 MSK
Probe with debug=1 option of iwlwifi: http://hw.rosalinux.ru/index.php?probe=52e1d6a188 (see dmesg with debug messages of iwlwifi).
Comment 3 Andrey Ponomarenko 2015-02-24 14:18:40 MSK
Added a bug to the kernel bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=93751
Comment 4 Andrey Ponomarenko 2015-02-26 13:11:25 MSK
The issue persists with the latest iwlwifi-7260-9.ucode firmware version 25.228.9.0: https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/linux-firmware.git/plain/iwlwifi-7260-9.ucode

HW probe: http://hw.rosalinux.ru/index.php?probe=674fff14a9
Comment 5 Andrey Ponomarenko 2015-04-28 17:40:45 MSD
The card has accidentally started to work with the old firmware (25.222.9.0) after latest OS updates: http://hw.rosalinux.ru/index.php?probe=9e69588bb8